summaryrefslogtreecommitdiff
path: root/dev-db/repmgr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/repmgr
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/repmgr')
-rw-r--r--dev-db/repmgr/Manifest5
-rw-r--r--dev-db/repmgr/metadata.xml7
-rw-r--r--dev-db/repmgr/repmgr-3.0.1.ebuild40
-rw-r--r--dev-db/repmgr/repmgr-3.3.2.ebuild40
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-db/repmgr/Manifest b/dev-db/repmgr/Manifest
new file mode 100644
index 000000000000..163a045c5f8d
--- /dev/null
+++ b/dev-db/repmgr/Manifest
@@ -0,0 +1,5 @@
+DIST repmgr-3.0.1.tar.gz 91724 BLAKE2B be0ac2d54dbaae7a45abaa90ed1a851e22f05a1bb0969a1c5d95e58d7c3f89513cc47555b77cc57bb5cd5baf60c21c9c44375363a757510f07b111ec78f87441 SHA512 5655745df18132ee53ff36f80b3a2bb8caa6cedd8091350464cf343386baa31c47d46b25c171dda0fd1f4c3402babea9864f4557a10659111449a2eb2e1fa2b9
+DIST repmgr-3.3.2.tar.gz 162107 BLAKE2B b1029297fa548241dc5d58bcdcffc0a6f749725eba2d3c7d2cb70b1f46a96b491dc27deb7baf8459e91eae9663df000a1713e80f05e7e0e39afc020b4136c9a4 SHA512 98fba8fc0d9074e496c66762dbec45734fe279f39c9c51adb3e66dca929ac37f66a609789c8c658545856fd81f5afc5b35f6b5e389e52bce8c04ce8c52acd8dd
+EBUILD repmgr-3.0.1.ebuild 1093 BLAKE2B b1bea77367d0485c85243730480fb97acc476606aa0db0587f1e3f2c70557456a489b84c88b70c17d14fb781bd27d505bd416ad57172ee0f56c2f47a67280105 SHA512 20196fa1f8819d40fb9eb2d72b76e4fe152ed1ac4ee4c35fd6b052af19ad8f3704888ffcae008869635661880a9e81076b012a2ecbd271e4553f74db1904930f
+EBUILD repmgr-3.3.2.ebuild 1093 BLAKE2B 8cce7fa79f044e9f5c5d459ee443f4d49b1dedb36e42e62670a39bb824d6e654dfd7c9c072a64dc40fa3ec9b89ea2c18d8f0e55954277877aabc89de781157db SHA512 6412c5cc1a9bde4fc6cac191146c0a529a67016690353b733547270198515b13ac56f9ecc081fb58eebe93b4afd03095001a9b4986e5f2ce55e3175c6893955b
+MISC metadata.xml 224 BLAKE2B e14c5e39ad6d95b550997301c1ff5fe7b690fc3a146c1b0811fd4d0441c09622fb029728028b464152abd3bb36b467dd4299fccd03d666a8755070b90e99d107 SHA512 823068733b2edd6bd6d3d211f2ec383dbc3571bb4f9a57fd0dd0f48633a99e90e4ee979cc82e9a8aca6667b0ebe6a66c1c76551dce88ed25f163ce9a25a9cd41
diff --git a/dev-db/repmgr/metadata.xml b/dev-db/repmgr/metadata.xml
new file mode 100644
index 000000000000..d8c0e2f2db10
--- /dev/null
+++ b/dev-db/repmgr/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ </pkgmetadata>
diff --git a/dev-db/repmgr/repmgr-3.0.1.ebuild b/dev-db/repmgr/repmgr-3.0.1.ebuild
new file mode 100644
index 000000000000..7a82e8739f28
--- /dev/null
+++ b/dev-db/repmgr/repmgr-3.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib
+DESCRIPTION="PostgreSQL Replication Manager"
+HOMEPAGE="http://www.repmgr.org/"
+SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-db/postgresql-9.3[server,static-libs]"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+ export PGSLOT="$(postgresql-config show)"
+ einfo "PGSLOT: ${PGSLOT}"
+ PGBASEDIR=/usr/$(get_libdir)/postgresql-${PGSLOT}
+ PGBINDIR=${PGBASEDIR}/bin/
+ PGCONTRIB=/usr/share/postgresql-${PGSLOT}/contrib/
+ dodir $PGCONTRIB $PGBINDIR
+ insinto $PGCONTRIB
+ doins sql/repmgr2_repmgr3.sql
+ dosym $PGBINDIR/repmgr /usr/bin/repmgr${PGSLOT//.}
+ dosym $PGBINDIR/repmgrd /usr/bin/repmgrd${PGSLOT//.}
+ dodoc CREDITS HISTORY COPYRIGHT TODO *.md *.rst
+ insinto /etc
+ newins repmgr.conf.sample repmgr.conf
+ fowners postgres:postgres /etc/repmgr.conf
+ ewarn "Remember to modify /etc/repmgr.conf"
+}
diff --git a/dev-db/repmgr/repmgr-3.3.2.ebuild b/dev-db/repmgr/repmgr-3.3.2.ebuild
new file mode 100644
index 000000000000..8aa275358e43
--- /dev/null
+++ b/dev-db/repmgr/repmgr-3.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib
+DESCRIPTION="PostgreSQL Replication Manager"
+HOMEPAGE="http://www.repmgr.org/"
+SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-db/postgresql-9.3[server,static-libs]"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+ export PGSLOT="$(postgresql-config show)"
+ einfo "PGSLOT: ${PGSLOT}"
+ PGBASEDIR=/usr/$(get_libdir)/postgresql-${PGSLOT}
+ PGBINDIR=${PGBASEDIR}/bin/
+ PGCONTRIB=/usr/share/postgresql-${PGSLOT}/contrib/
+ dodir $PGCONTRIB $PGBINDIR
+ insinto $PGCONTRIB
+ doins sql/repmgr2_repmgr3.sql
+ dosym $PGBINDIR/repmgr /usr/bin/repmgr${PGSLOT//.}
+ dosym $PGBINDIR/repmgrd /usr/bin/repmgrd${PGSLOT//.}
+ dodoc CREDITS HISTORY COPYRIGHT TODO *.md *.rst
+ insinto /etc
+ newins repmgr.conf.sample repmgr.conf
+ fowners postgres:postgres /etc/repmgr.conf
+ ewarn "Remember to modify /etc/repmgr.conf"
+}