summaryrefslogtreecommitdiff
path: root/dev-db/repmgr/repmgr-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-db/repmgr/repmgr-5.1.0.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-db/repmgr/repmgr-5.1.0.ebuild')
-rw-r--r--dev-db/repmgr/repmgr-5.1.0.ebuild32
1 files changed, 19 insertions, 13 deletions
diff --git a/dev-db/repmgr/repmgr-5.1.0.ebuild b/dev-db/repmgr/repmgr-5.1.0.ebuild
index 06a26ac1e9b5..2691cff57149 100644
--- a/dev-db/repmgr/repmgr-5.1.0.ebuild
+++ b/dev-db/repmgr/repmgr-5.1.0.ebuild
@@ -1,38 +1,44 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils multilib
+
DESCRIPTION="PostgreSQL Replication Manager"
HOMEPAGE="http://www.repmgr.org/"
SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-db/postgresql-9.3[server,static-libs]"
+DEPEND="dev-db/postgresql:*[server,static-libs]"
RDEPEND="${DEPEND}
net-misc/rsync"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_compile() {
emake USE_PGXS=1
}
src_install() {
emake DESTDIR="${D}" USE_PGXS=1 install
- export PGSLOT="$(postgresql-config show)"
+ dodoc CREDITS HISTORY COPYRIGHT *.md
+
+ local PGSLOT="$(postgresql-config show)"
einfo "PGSLOT: ${PGSLOT}"
- PGBASEDIR=/usr/$(get_libdir)/postgresql-${PGSLOT}
- PGBINDIR=${PGBASEDIR}/bin/
- PGCONTRIB=/usr/share/postgresql-${PGSLOT}/contrib/
- dodir $PGCONTRIB $PGBINDIR
- dosym $PGBINDIR/repmgr /usr/bin/repmgr${PGSLOT//.}
- dosym $PGBINDIR/repmgrd /usr/bin/repmgrd${PGSLOT//.}
- dodoc CREDITS HISTORY COPYRIGHT *.md
+
+ dodir /usr/share/postgresql-${PGSLOT}/contrib
+ dodir /usr/$(get_libdir)/postgresql-${PGSLOT}
+
+ local repmgr="/usr/bin/repmgr${PGSLOT//.}"
+ local repmgrd="/usr/bin/repmgrd${PGSLOT//.}"
+ dosym ../$(get_libdir)/postgresql-${PGSLOT}/bin/repmgr ${repmgr}
+ dosym ../$(get_libdir)/postgresql-${PGSLOT}/bin/repmgrd ${repmgrd}
+
insinto /etc
newins repmgr.conf.sample repmgr.conf
+
fowners postgres:postgres /etc/repmgr.conf
ewarn "Remember to modify /etc/repmgr.conf"
}