summaryrefslogtreecommitdiff
path: root/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-13 06:19:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-13 06:19:51 +0000
commit8be70107efbb417f839292165ee39d07a062046f (patch)
tree013918887ec4a00f0cefdb4b4d1313cbc3054305 /dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
parent343a7272d559a21a0e0ed13cb743fabb2bfcc479 (diff)
gentoo resync : 13.01.2018
Diffstat (limited to 'dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild')
-rw-r--r--dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild b/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
new file mode 100644
index 000000000000..a7d8360210f1
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iodbc ssl threads"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dodoc docs/*{html,jpg,txt}
+}