summaryrefslogtreecommitdiff
path: root/dev-db/postgresql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-21 11:14:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-21 11:14:12 +0100
commit03633f33c2184a87f7a4cebae72542343cf0490c (patch)
tree51a044dec7586be070d68ebb95d563883b02c726 /dev-db/postgresql
parentc0e834f207174ee62c093753cea0176c947a9ba1 (diff)
gentoo auto-resync : 21:09:2023 - 11:14:12
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/Manifest2
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild138
2 files changed, 56 insertions, 84 deletions
diff --git a/dev-db/postgresql/Manifest b/dev-db/postgresql/Manifest
index feb7758c3577..d66ecd07ef24 100644
--- a/dev-db/postgresql/Manifest
+++ b/dev-db/postgresql/Manifest
@@ -21,5 +21,5 @@ EBUILD postgresql-13.12.ebuild 13746 BLAKE2B 3a15dbec81c68fb5a5702e9a50703a611f2
EBUILD postgresql-14.9.ebuild 13738 BLAKE2B f6e41a0679cf7d6caf99e5e5969303140ec7d6181e8ea9fa8141e36cab99d36021de24dd66382327c0850a6f6bcd0bf9c9af1b179ac94be3b6f93b2eccc499db SHA512 e43c114b990ef2fb8e1fc0b08ba9c4e462a7fe68c76b6a6225cabd9cda1e01bf4e2d31743464095ed7e9588ac08ec408f55e3a6e112cf73c4b97cc8138e3042d
EBUILD postgresql-15.4.ebuild 13797 BLAKE2B 8148aba8558794f0996561a99169e06037c793ab5fa574afe643614e7e96d20feed972b979d18e61f0384a468b05eefa942ef37f770d60022c91fd2e98c3d2b8 SHA512 37e62011a0c70560858e353f6677e0ce82f4218dbb07f52fecb10dc05a51ef3013708828a0bdcf15eb23d8a54a15a44559292e67a2770a64c80f92d9d5bdf8ef
EBUILD postgresql-16.0.ebuild 13808 BLAKE2B 224b5bcdaab9c079a713aa901eeb7ebbe8d94df99b018cd6c2a6da0e6dc80ebaeab7a775aae809b3fc610df1f41dafbac9106c4ecd352fdc9235799ae947d247 SHA512 3c4879f18f6a542efd9acae5c53f40b9794755e196ae6d26e71dd4f6896ad0df36777f19680931dd07c495333eae14b37e6902831a68bfcea423237393b83003
-EBUILD postgresql-9999.ebuild 13947 BLAKE2B 85800dee3caf42c402de2db57e2fe6ea7b6bfa4917003ed01b10f455c6964c6d4dfae69e273cfc7f9c746c7b74ba149e8ebac81afeecbb0eb18c350cdde7fc6c SHA512 a44f0ecdb53b83877253bff36e79c9e237d17b3af2230fd2c680506cf87a0eaaa153ba037df1b008af4ed02a8224ee21b486978241e68f1a14084912f53d1aab
+EBUILD postgresql-9999.ebuild 12920 BLAKE2B fba75d4d6bb85194b39c35b56884e799cf4c75d2fc412768dd253796b4ed825060b757f448c3d5ff596cc67d247a6176955857fbb85898032df47ea133b53f87 SHA512 e341b6e6cc3b3e9ecd3dacaafbcd0ef826a30fa0c11238937533f8a5877f773b57be5a0b56eabb7b946f81cfc1cfad73f83caa414668d89b49eb6e585771c360
MISC metadata.xml 653 BLAKE2B b5b85d83ee78ac502e2707d156e2fadf6fea857160e2f48da51c755e221c52a14b9eb04354202287f4aba15c274c07ba7b0911c76fd034bfa774ce3500ccb165 SHA512 fd543af224f6f8677e138cb1db7154d2444295c45df8696e3584911943176023d8d1b179f6b16d88ffc6d290265ec1b2f4c902cf95cc79eb37599ae3635b0942
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index ff52cfb7a800..61fdcbecf890 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -5,7 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{10,11,12} )
-inherit flag-o-matic git-r3 linux-info pam python-single-r1 systemd tmpfiles
+inherit flag-o-matic git-r3 linux-info meson pam python-single-r1 \
+ systemd tmpfiles
KEYWORDS=""
@@ -92,7 +93,7 @@ pkg_pretend() {
if ! use server; then
elog "You are using a live ebuild that uses the current source code as it is"
elog "available from PostgreSQL's Git repository at emerge time. Given such,"
- elog "the GNU Makefiles may be altered by upstream without notice and the"
+ elog "the Meson build files may be altered by upstream without notice and the"
elog "documentation for this live version is not readily available"
elog "online. Ergo, the ebuild maintainers will not support building a"
elog "client-only and/or document-free version."
@@ -126,68 +127,76 @@ src_prepare() {
}
src_configure() {
+ local emesonargs=()
+
case ${CHOST} in
*-darwin*|*-solaris*)
use nls && append-libs intl
;;
esac
- export LDFLAGS_SL="${LDFLAGS}"
- export LDFLAGS_EX="${LDFLAGS}"
-
- local PO="${EPREFIX}"
-
local i uuid_config=""
if use uuid; then
for i in ${UTIL_LINUX_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=e2fs"
+ use ${i} && uuid_config="-Duuid=e2fs"
done
- [[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
- fi
- local myconf="\
- --prefix="${PO}/usr/$(get_libdir)/postgresql-${SLOT}" \
- --datadir="${PO}/usr/share/postgresql-${SLOT}" \
- --includedir="${PO}/usr/include/postgresql-${SLOT}" \
- --mandir="${PO}/usr/share/postgresql-${SLOT}/man" \
- --sysconfdir="${PO}/etc/postgresql-${SLOT}" \
- --with-system-tzdata="${PO}/usr/share/zoneinfo" \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_with icu) \
- $(use_with kerberos gssapi) \
- $(use_with ldap) \
- $(use_with llvm) \
- $(use_with lz4) \
- $(use_with pam) \
- $(use_with perl) \
- $(use_with python) \
- $(use_with readline) \
- $(use_with ssl openssl) \
- $(use_with tcl) \
- $(use_with xml libxml) \
- $(use_with xml libxslt) \
- $(use_with zlib) \
- $(use_with zstd ) \
- $(use_with systemd) \
- ${uuid_config}"
- if use alpha; then
- myconf+=" --disable-spinlocks"
- else
- # Should be the default but just in case
- myconf+=" --enable-spinlocks"
+ emesonargs+=( ${uuid_config:-"-Duuid=ossp"} )
fi
- econf ${myconf}
+
+ use debug && emesonargs+=( "--debug" )
+
+ local PO="${EPREFIX}"
+ emesonargs+=(
+ --prefix="${PO}/usr/$(get_libdir)/postgresql-${SLOT}"
+ --datadir="${PO}/usr/share/postgresql-${SLOT}"
+ --includedir="${PO}/usr/include/postgresql-${SLOT}"
+ --mandir="${PO}/usr/share/postgresql-${SLOT}/man"
+ --sysconfdir="${PO}/etc/postgresql-${SLOT}"
+ -Dsystem_tzdata="${PO}/usr/share/zoneinfo"
+ $(meson_feature icu)
+ $(meson_feature kerberos gssapi)
+ $(meson_feature ldap)
+ $(meson_feature llvm)
+ $(meson_feature lz4)
+ $(meson_feature nls)
+ $(meson_feature pam)
+ $(meson_feature perl plperl)
+ $(meson_feature python plpython)
+ $(meson_feature readline)
+ $(meson_feature systemd)
+ $(meson_feature tcl pltcl)
+ $(meson_feature xml libxml)
+ $(meson_feature xml libxslt)
+ $(meson_feature zlib)
+ $(meson_feature zstd)
+ )
+
+ use ssl && emesonargs+=( "-Dssl=openssl" )
+ use alpha && emesonargs+=( "-Dspinlocks=false" )
+
+ export LDFLAGS_SL="${LDFLAGS}"
+ export LDFLAGS_EX="${LDFLAGS}"
+
+ meson_src_configure
}
src_compile() {
- emake world
+ meson_src_compile
+ meson_src_compile {docs,man}
}
src_install() {
- emake DESTDIR="${D}" install-world
+ meson_src_install
dodoc README HISTORY doc/TODO
+ dodoc -r "${BUILD_DIR}"/doc/src/sgml/html
+
+ # postgresql.eselect places the man files of the selected slot, which may
+ # not be this ${SLOT}, hence doins instead of doman
+ insinto /usr/share/postgresql-${SLOT}/man/
+ doins -r "${BUILD_DIR}"/doc/src/sgml/man{1,3,7}
+ docompress /usr/share/postgresql-${SLOT}/man/man{1,3,7}
insinto /etc/postgresql-${SLOT}
newins src/bin/psql/psqlrc.sample psqlrc
@@ -220,11 +229,8 @@ src_install() {
-mindepth 1 -maxdepth 1)
do
bn=$(basename "${f}")
- # Temporarily tack on tmp to workaround a file collision
- # issue. This is only necessary for 9.7 and earlier. 10 never
- # had this issue.
dosym "../$(get_libdir)/postgresql-${SLOT}/bin/${bn}" \
- "/usr/bin/${bn}${SLOT/.}tmp"
+ "/usr/bin/${bn}${SLOT/.}"
done
# Create slot specific man pages
@@ -257,40 +263,6 @@ src_install() {
fi
}
-pkg_preinst() {
- # Find all of the slot-specific symlinks, if any, in /usr/bin (e.g.,
- # /usr/bin/psql97). They may have been created by the
- # postgresql.eselect module, but they're handled within this ebuild
- # now. It's alright if we momentarily delete /usr/bin/psql as it
- # will be recreated by the eselect module in pkg_ppostinst(). We
- # only worry about the 9.7 slot as that's the last slot that had its
- # slot-specific links generated by eselect.
- #
- # This can be removed when 10 is the lowest slot in the tree.
- local canonicalise
- if type -p realpath > /dev/null; then
- canonicalise=realpath
- elif type -p readlink > /dev/null; then
- canonicalise='readlink -f'
- else
- # can't die, subshell
- die "No readlink nor realpath found, cannot canonicalise"
- fi
-
- local l
- # First remove any symlinks in /usr/bin that may have been created
- # by the old eselect
- for l in $(find "${ROOT}/usr/bin" -mindepth 1 -maxdepth 1 -type l) ; do
- [[ $(${canonicalise} "${l}") == *postgresql-9.7* ]] && rm "${l}"
- done
-
- # Then move the symlinks created by the ebuild to their proper place.
- for l in "${ED}"/usr/bin/*tmp ; do
- mv "${l}" "${l%tmp}" \
- || ewarn "Couldn't rename $(basename ${l}) to $(basename ${l%tmp})"
- done
-}
-
pkg_postinst() {
use systemd && tmpfiles_process ${PN}-${SLOT}.conf
postgresql-config update
@@ -458,7 +430,7 @@ src_test() {
# LC_CTYPE to be equal to LC_COLLATE since LC_COLLATE is set by Portage.
local old_ctype=${LC_CTYPE}
export LC_CTYPE=${LC_COLLATE}
- emake check
+ meson_src_test
export LC_CTYPE=${old_ctype}
einfo "If you think other tests besides the regression tests are necessary, please"