summaryrefslogtreecommitdiff
path: root/dev-db/postgis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
commit5b5df25227111ef465caf5c52bcfb66dac3219cd (patch)
tree31b713cac6188358125cbb66b8804030328740f0 /dev-db/postgis
parent02e2208f46f4e2c00fb9743cbc47350bdd233bfa (diff)
gentoo resync : 19.01.2018
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/Manifest2
-rw-r--r--dev-db/postgis/postgis-2.4.3.ebuild126
2 files changed, 128 insertions, 0 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index 1bad1a6d0947..dd86c37abfcc 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -1,6 +1,8 @@
AUX postgis-2.2.0-arflags.patch 535 BLAKE2B 6420573e9623d4e2115ed3616bc3b8648ae7782bf4624ee60d3827a4d61cbdac1dc62b4937f36113ed6d0856af4728f5cc1b544d502512e88dd87a7b590135ab SHA512 7f8b92a582dd11b3040832278b75e65036315ca0e438cb9b19cc5b63a7b5c5bcae8ec274a487a29abadfbbc31cdfacf6c668e46f249d4bf88c09607501cacf66
AUX postgis-2.4.2-jsonc_0.13.patch 786 BLAKE2B c55fd81f28b9a4db965ef3f4bb3ca6fcf2cd6ba44d4f7a93c35ade90ffdcb195325ce219348aa6dc3645f6822214b4bc75263c02fc316f3dd9b4369114eb5493 SHA512 9088304bb77db2d86dd077510f94ae8b3796474a02377f1f076476c739d9506f0b7c7c6dcf6e90ad51e84bc528302a6ecda4bedc6eac42dfeba3a71c0144a399
DIST postgis-2.4.2.tar.gz 12470881 BLAKE2B 116bb5d1c8f6066d537cac950254923a681babac456d155139dbdd2853b80499f4f9445dad985b94bffffd1d1285a6c78fee0fccb24e301d18147f3cd9230416 SHA512 e268572d5cd009754ef05f5d2eedcac7e362fa47199459c637cd4d9050d2b648d4b2b3746cde0dce5a42be2606a432b64dc905f193e12cf0869e3dd6f820b425
+DIST postgis-2.4.3.tar.gz 12601055 BLAKE2B 662b2afe145bc23c77ebda7306d07a20e39c1a598316cee58e1591e65ce1b2d2a3f727f5463ba144711faa55f7c11e4a038b6ad2a76cab760b4fdd43647f09c3 SHA512 95b2c925cb10943e7136aa3b7b08a9ad3d6ff59a3994c653bba52e4c65193d519daa49684b924f68945dd596187aa17e0c713bf0b9e29f8c5973346b279dba1b
EBUILD postgis-2.4.2.ebuild 3111 BLAKE2B d8b8673824c2cbc0934f5e384549abe379dae7534f406cf0fb2ddfb5ba6100176f335028a6db2be0caec341fa07781d2542dab2d0262b79239171e55955fc199 SHA512 ada96e8ae149e765da8cd9d689b563cff87332277df84ecf12b093b691ea97da4ee3994c19efcc545cecd99fe882641884363845abbb940d6c7baa45878a40c9
+EBUILD postgis-2.4.3.ebuild 3113 BLAKE2B 975e5108a5e6ccd1e94dcd35bf3201299850c986295c5f980d3f8c2e4e458e05e668d8df67fdf6c6796d9390e5ce917ed5a45c45c6cb5b9f9d7eae69514cde62 SHA512 24aa6ccf5c6b44fd411090833b294c336f1bcfc487f80baa87512388dfd8967fe9776ffc21f1d3e902055f8779194926793673ddbdcb1e6d9a73e569513d14e7
EBUILD postgis-9999.ebuild 2647 BLAKE2B b379c0ebfd30c407817139b72264bbb70c0cae3ba281b2f2ffda38c61c851bb363266e2675437e32dd3ffc80a6c1dca4608e34833d7a729cbd6997eb2501411d SHA512 4b654b604752b9e30ea0662e89429e0deb74e1ce6cfb8beef34f8bf33ea2aeb28e07398828fc5ddc3d27a520258313cb552b7ef24069ca5b9001a4db7aaa1cec
MISC metadata.xml 779 BLAKE2B 9dfbc86514c5f6e0c859dc41a46890e4f518f23c572786bf340112eadf21b35f5f583a3835f6ba58bef8c99a7ef8483f3a98898d372d1c0e5cc537bb9ecc2b12 SHA512 33ad2ddabf49e97af2cf188f2c0f72e1a936c228b43d8d3637230c43be0df82ec2aa20b63cb5f2385e936c215263fcd009332afe504bc5f30746a387b9b37ada
diff --git a/dev-db/postgis/postgis-2.4.3.ebuild b/dev-db/postgis/postgis-2.4.3.ebuild
new file mode 100644
index 000000000000..205ce7a381ce
--- /dev/null
+++ b/dev-db/postgis/postgis-2.4.3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+POSTGRES_COMPAT=( 9.{2..6} 10 )
+POSTGRES_USEDEP="server"
+
+inherit autotools eutils postgres-multi versionator
+
+MY_PV=$(replace_version_separator 3 '')
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="http://postgis.net"
+SRC_URI="http://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="address-standardizer doc gtk static-libs mapbox test topology"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ >=sci-libs/geos-3.5.0
+ >=sci-libs/proj-4.6.0
+ >=sci-libs/gdal-1.10.0
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+ mapbox? ( dev-libs/protobuf )
+"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[imagemagick,png]
+ )
+ )
+ virtual/pkgconfig
+ test? ( dev-util/cunit )
+"
+
+PGIS="$(get_version_component_range 1-2)"
+
+REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+MAKEOPTS+=' -j1'
+
+# These modules are built using the same *FLAGS that were used to build
+# dev-db/postgresql. The right thing to do is to ignore the current
+# *FLAGS settings.
+QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch" \
+ "${FILESDIR}/postgis-2.4.2-jsonc_0.13.patch"
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ local myargs=""
+
+ use gtk && myargs+=" --with-gui"
+
+ use address-standardizer || myargs+=" --without-address-standardizer"
+ use mapbox || myargs+=" --without-protobuf"
+ use topology || myargs+=" --without-topology"
+
+ postgres-multi_foreach econf ${myargs}
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "http://postgis.net/docs/manual-${PGIS}/postgis_installation.html#create_new_db_extensions"
+}