summaryrefslogtreecommitdiff
path: root/dev-db/phppgadmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-db/phppgadmin
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/Manifest4
-rw-r--r--dev-db/phppgadmin/files/postinstall-en.txt4
-rw-r--r--dev-db/phppgadmin/metadata.xml11
-rw-r--r--dev-db/phppgadmin/phppgadmin-7.12.1.ebuild38
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-db/phppgadmin/Manifest b/dev-db/phppgadmin/Manifest
new file mode 100644
index 000000000000..e08cb6609b67
--- /dev/null
+++ b/dev-db/phppgadmin/Manifest
@@ -0,0 +1,4 @@
+AUX postinstall-en.txt 162 BLAKE2B d08f1f1064e8f268fe92ee622d0b5a756e20d80a6376abf1bfc7e8bb88c90d7b3c1b7c3c3291d3189791cca9766feb05b9831ddcba2e84f69e295f7048d440e7 SHA512 3aa9e4b58ffd97cc9bc990e0ca8444e8be012fb56859b28705e7ed3d5ffae74bcfab19c55e415785c9f09fabcc20ea5a493ee2f03fb380a351c02fe958231bd8
+DIST phpPgAdmin-7.12.1.tar.bz2 579723 BLAKE2B 58d4992424fb6c9bf8565843c6d76ceecb68212cc311d15d43303fd6b63fe2a611ce146761b8f6b8f992798060d065a0b0e528aed5df217a3078cef9e56c49da SHA512 d64b4796c5acad990ef81b12ebd377474d04c1a65adc41a91a2d278bb975812389bb6eae23490de3f5ce09502d36adea3cacfdec0e868c6a0e0bcb639b8a94db
+EBUILD phppgadmin-7.12.1.ebuild 904 BLAKE2B 5edf5c459e40fee4acad3bf7f07a58e9dc48619696e7d9d639ea87ba69df3c50d510239e8b7e6350c148de88255f7f15d8e94edecc17462a96b584a398bc800f SHA512 e29a5deb56a2825f16547ccb8b1d086cb6b3ec7ae037a8a994e92acc488a7da56db5698f816933f24ca0dcc17099a0c9387cd44ba458b70b94674efd4d9b9cf8
+MISC metadata.xml 327 BLAKE2B 3dae61a226e7d8c513f4a6675fec1f61489750f2ad21c0d36600fe6e08b4dabf990182bb74a01176e55b4a4b4fe429b7c7830c17bb574e0daf5788f81504ba59 SHA512 ef827397746f3666035223238cf33a7a92bce8addaab1958e94e85f0c4f64ec396db0498264928e717210fb9711c15b059c203cd05e412bbaf3c2b9abb914e28
diff --git a/dev-db/phppgadmin/files/postinstall-en.txt b/dev-db/phppgadmin/files/postinstall-en.txt
new file mode 100644
index 000000000000..003fe5003bbd
--- /dev/null
+++ b/dev-db/phppgadmin/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+Make sure you edit ${MY_INSTALLDIR}/conf/config.inc.php
+
+To use the reports database, you have to manually execute
+psql -f ${MY_INSTALLDIR}/sql/reports-pgsql.sql
diff --git a/dev-db/phppgadmin/metadata.xml b/dev-db/phppgadmin/metadata.xml
new file mode 100644
index 000000000000..8390195bb165
--- /dev/null
+++ b/dev-db/phppgadmin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">phppgadmin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/phppgadmin/phppgadmin-7.12.1.ebuild b/dev-db/phppgadmin/phppgadmin-7.12.1.ebuild
new file mode 100644
index 000000000000..e0ec4521ab80
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-7.12.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/REL_$(ver_rs 1- -)/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/php[postgres,session]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}