summaryrefslogtreecommitdiff
path: root/dev-db/pgtap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
commit2b2f431a0021b4787ca3c028cefb30ad81347778 (patch)
tree951e0155f53027c8fd29eaba26df4f08292668d5 /dev-db/pgtap
parentd725480af7cbc67d784e5d96f973fa41e9030123 (diff)
gentoo auto-resync : 19:01:2024 - 20:08:27
Diffstat (limited to 'dev-db/pgtap')
-rw-r--r--dev-db/pgtap/Manifest4
-rw-r--r--dev-db/pgtap/pgtap-1.2.0-r2.ebuild3
-rw-r--r--dev-db/pgtap/pgtap-1.3.1.ebuild37
3 files changed, 41 insertions, 3 deletions
diff --git a/dev-db/pgtap/Manifest b/dev-db/pgtap/Manifest
index bbedb323a3b2..85b9a2bbfc61 100644
--- a/dev-db/pgtap/Manifest
+++ b/dev-db/pgtap/Manifest
@@ -1,3 +1,5 @@
DIST pgtap-1.2.0.zip 319374 BLAKE2B 1cea77860a1928ed7cbf4ddb0bb8ff418023bf88e377196ae2b505c065321e3003179227077567e676a8c551230d259ecd1cdb590001fc71bcc821b87fb3d0f6 SHA512 5569bea5e7879787a91fa9b2baae5cbff1db5b9a5a096db2a9a064012d65e02c52bd1520422b5e6f87fb5b6e64845371188ea53c43a277aee68ffc05d5152ed7
-EBUILD pgtap-1.2.0-r2.ebuild 796 BLAKE2B 5f54b8291e1b1879836a9e599cdd26ed9e1deb1f0c1c3a2714928c284a7197827e336fc60e9b7ab84278c745ef3a07a79d335c8c5610de9b49c9315ab0ef8052 SHA512 52c4f031f84b5d75d05e5d57d56cc67834123c47f440ac9c10ed689ded80585568a7327c6a6398a73cfc312af30cb58c9c183a61902bb73f49e12c1dccea631f
+DIST pgtap-1.3.1.zip 654637 BLAKE2B 412dfcb51813552541f935328e28fbf8f0a014536a5eee8bf55ea680cd22a6424529641040627f91afebb407872d8d3d4aa25e576d965ddb11514229c2b72591 SHA512 98129bbbdf2221502e52375c3e55dff324e69cb930865d1589949ad2d96ddeac1a215e10d0612f7cc050d9a725817b01b23a9cc3e9cb42ef23a929e593ecb698
+EBUILD pgtap-1.2.0-r2.ebuild 788 BLAKE2B 33641422ba4105824dc10647f5097959d0c34e3f8f86ddf70807501b6e1bb150e202447e608293b25f39f2c59190c9e74b0fb22282223e9bc0101434913da3a8 SHA512 0723081946ef8db4dc7be3a6923351e89e970227ecce05cfe09bdeae1241db096d23d5901072beb299a9fc3082373e67792b84f3e8b0f1f9f93c231cb34e7ac4
+EBUILD pgtap-1.3.1.ebuild 784 BLAKE2B c595aea0ca4ee8b34dfdd2713b685363bd49367b1940bf931847611a7ea8604d90259db1942b8a59b3f4817ec7be56506e860afd900192d0425b46685b86a983 SHA512 9f2b7ec33fce20904494c6d42d5a44e2840aac539dcc083cd363d1a9fff53813197f2d33fd42283680e82e84da79094e432b58ff6a44e4b95344a901b06b831e
MISC metadata.xml 629 BLAKE2B e7052e443d1a9c728bce35231d7aa287b2844409cc69ecb42b563000a7908e1db49d1a85fe01e8bcafb27fc2741181869895582a77286a0eb16b101ca672d3c4 SHA512 9a3f6c41f8a6577b0c2e29d81549644cf2c74f742aa3f4fca182e6588cc380ac3d2fa5ca07b931d41b24ba0021b81f462d316071ecaa1c3d813cbfa76603f063
diff --git a/dev-db/pgtap/pgtap-1.2.0-r2.ebuild b/dev-db/pgtap/pgtap-1.2.0-r2.ebuild
index a62f1fe0a5ee..a4658a7fd8c6 100644
--- a/dev-db/pgtap/pgtap-1.2.0-r2.ebuild
+++ b/dev-db/pgtap/pgtap-1.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,6 @@ SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
DEPEND="${POSTGRES_DEP}
app-arch/unzip
diff --git a/dev-db/pgtap/pgtap-1.3.1.ebuild b/dev-db/pgtap/pgtap-1.3.1.ebuild
new file mode 100644
index 000000000000..6ecd9a456893
--- /dev/null
+++ b/dev-db/pgtap/pgtap-1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( {12..16} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_install() {
+ postgres-multi_src_install
+
+ rm -r "${ED}"/usr/share/doc/postgresql* || die "Failed to remove improper doc locations"
+ dodoc doc/pgtap.mmd
+}