summaryrefslogtreecommitdiff
path: root/dev-db/pgrouting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-16 02:01:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-16 02:01:58 +0000
commite07c6f9648d478943b5ecd6f1c42cc91cae0f547 (patch)
tree2c56c6944fb4016ee510ee97a1a158baf49edfe4 /dev-db/pgrouting
parent16a4365c3b854e62b50726456ddb29bb78fd5038 (diff)
gentoo auto-resync : 16:12:2024 - 02:01:58
Diffstat (limited to 'dev-db/pgrouting')
-rw-r--r--dev-db/pgrouting/Manifest2
-rw-r--r--dev-db/pgrouting/pgrouting-3.7.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/pgrouting/Manifest b/dev-db/pgrouting/Manifest
index c103d9ee8a58..fe925569c105 100644
--- a/dev-db/pgrouting/Manifest
+++ b/dev-db/pgrouting/Manifest
@@ -1,3 +1,5 @@
DIST pgrouting-3.6.2.tar.gz 3873384 BLAKE2B 118d57018d344055e3a7d7daef07f0f8916918b907d7d7dd5d63e22c8df0315089ab6b52f6a70b5dea4390e9f432cec602c798f46557bac2aa69f69e4d5b8555 SHA512 9fe5649d022bc1330d9f70e42a69de45eaed9fce070f58594996516f295a7bc15c099b2c3ee1c25ee4b4f0d839de4c0cc74174972e7f7f0dc5fa4be395d58dd3
+DIST pgrouting-3.7.0.tar.gz 3870824 BLAKE2B 19f5327dd76311e9ec1409c5e77fc59c599f2b22b847fb936f11e891d433fb43629dd2f2223cb923f45f7ebbcdd58cb749076851f3d0a980953e257adc3a3265 SHA512 8ebe82a6c0e6d2974d298fbdb2b3d48304da76395da5459183e8ade56b247e179b606fc3a6ab60478696a0dd9671be20995b1f13beb61df2393d4f36050baf23
EBUILD pgrouting-3.6.2.ebuild 1045 BLAKE2B c6b72fdc6e01cfdb1b2feaf91865a481b4c05942b5d2c4794a3a5cb91627a6272b5fdb2f5022f269d0d03f7f866d59571e1418029b1fd669dffa090917ab4dd9 SHA512 9b7ee0a47e7f00283aece900f6eb71df9a6f5bd3e2f49723f74f09d23fe1cc51120850b5c0b1946265eb296c477dbd5ad3b5d862af661e76ddd55485091d83f6
+EBUILD pgrouting-3.7.0.ebuild 1045 BLAKE2B 1313856606fb2ba9be42f2a93f7da6a197d3530fc0811d3634fbb54fed1164cd1e7dbf2afff9054945f81a62a42eaec05288f30f82ae1c0cd42971ac8845d1f2 SHA512 2c9f1168423c290d3221d54b52433b44d28893c7ab59ba84dfc00fa7493a98fc66913e3c9f3f1d26d161f925ccb41da636bc4c493afad2e766c6c08a0dcc8ae1
MISC metadata.xml 375 BLAKE2B e6c25b3d8331162daad5c8cf73b35340bb5092e219d0300be1aa2b36f6d73044b7ddb883cf15e633f8837ef12716a779bfc968112cba418dfed9d106a86ce076 SHA512 b01c3c837b862519087f831bf7ab7de2add4a6fee5b8c7e78b551fe6c4bed59d3f30e7871defe16c25271fdafa5e1d8bc6da250ed22bd1f2476e05fcd3a3d7d0
diff --git a/dev-db/pgrouting/pgrouting-3.7.0.ebuild b/dev-db/pgrouting/pgrouting-3.7.0.ebuild
new file mode 100644
index 000000000000..20e088526f62
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-3.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+
+POSTGRES_COMPAT=( {13..16} )
+POSTGRES_USEDEP="server"
+
+inherit cmake postgres-multi
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality"
+HOMEPAGE="https://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ sci-mathematics/cgal
+"
+
+DEPEND="${RDEPEND}"
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+ postgres-multi_src_prepare
+}
+
+my_src_configure() {
+ local mycmakeargs=( -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)" )
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach my_src_configure
+}
+
+src_compile() {
+ postgres-multi_foreach cmake_build
+}
+
+src_install() {
+ postgres-multi_foreach cmake_src_install
+}