summaryrefslogtreecommitdiff
path: root/dev-db/pgrouting/pgrouting-3.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
commitfbba40085f5d1591a67b49f5aa48b4071b7560f1 (patch)
tree09e69d990e9c6d078ad475802b8728fa703bac9a /dev-db/pgrouting/pgrouting-3.1.3.ebuild
parent42e82780761e75f17a5cc96626558a297782f385 (diff)
gentoo auto-resync : 10:06:2023 - 21:52:51
Diffstat (limited to 'dev-db/pgrouting/pgrouting-3.1.3.ebuild')
-rw-r--r--dev-db/pgrouting/pgrouting-3.1.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-db/pgrouting/pgrouting-3.1.3.ebuild b/dev-db/pgrouting/pgrouting-3.1.3.ebuild
deleted file mode 100644
index e9e3411c48f7..000000000000
--- a/dev-db/pgrouting/pgrouting-3.1.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_BUILD_TYPE="Release"
-
-POSTGRES_COMPAT=( 9.6 {10..13} )
-POSTGRES_USEDEP="server"
-
-inherit cmake postgres-multi
-
-DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality"
-HOMEPAGE="https://pgrouting.org/"
-LICENSE="GPL-2 MIT Boost-1.0"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE=""
-
-RDEPEND="${POSTGRES_DEP}
- >=dev-db/postgis-2.0
- dev-libs/boost
- sci-mathematics/cgal
-"
-
-DEPEND="${RDEPEND}"
-# Needs a running psql instance, doesn't work out of the box
-RESTRICT="test"
-
-src_prepare() {
- cmake_src_prepare
- postgres-multi_src_prepare
-}
-
-my_src_configure() {
- local mycmakeargs=( -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)" )
- cmake_src_configure
-}
-
-src_configure() {
- postgres-multi_foreach my_src_configure
-}
-
-src_compile() {
- postgres-multi_foreach cmake_build
-}
-
-src_install() {
- postgres-multi_foreach cmake_src_install
-}