summaryrefslogtreecommitdiff
path: root/dev-db/pgcli/pgcli-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-db/pgcli/pgcli-2.0.2.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-db/pgcli/pgcli-2.0.2.ebuild')
-rw-r--r--dev-db/pgcli/pgcli-2.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/pgcli/pgcli-2.0.2.ebuild b/dev-db/pgcli/pgcli-2.0.2.ebuild
new file mode 100644
index 000000000000..a357d5239431
--- /dev/null
+++ b/dev-db/pgcli/pgcli-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/prompt_toolkit-2.1.0[${PYTHON_USEDEP}]
+ <dev-python/psycopg-2.8[${PYTHON_USEDEP}]
+ <dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/humanize-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/keyring-12.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pgspecial-1.11.5[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.1.9[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"