summaryrefslogtreecommitdiff
path: root/dev-db/pgagent/pgagent-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-db/pgagent/pgagent-4.0.0.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-db/pgagent/pgagent-4.0.0.ebuild')
-rw-r--r--dev-db/pgagent/pgagent-4.0.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-db/pgagent/pgagent-4.0.0.ebuild b/dev-db/pgagent/pgagent-4.0.0.ebuild
deleted file mode 100644
index dab33c73221a..000000000000
--- a/dev-db/pgagent/pgagent-4.0.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake-utils user
-
-MY_PN=${PN/a/A}
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
-HOMEPAGE="https://www.pgadmin.org/download/pgagent-source-code/"
-SRC_URI="https://ftp.postgresql.org/pub/pgadmin/${PN}/${MY_PN}-${PV}-Source.tar.gz"
-
-LICENSE="POSTGRESQL GPL-2"
-SLOT="0"
-
-RDEPEND="dev-db/postgresql:*
- dev-libs/boost
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}-Source"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -e "s:share):share/${P}):" \
- -i CMakeLists.txt || die "failed to patch CMakeLists.txt"
-}
-
-src_configure() {
- mycmakeargs=( "-DSTATIC_BUILD:BOOLEAN=FALSE"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- newinitd "${FILESDIR}/pgagent.initd-r1" "${PN}"
- newconfd "${FILESDIR}/pgagent.confd" "${PN}"
-
- rm "${ED}"/usr/{LICENSE,README} || die "failed to remove useless docs"
-}
-
-pkg_preinst() {
- # This user needs a real shell, and the daemon will use the
- # ~/.pgpass file from its home directory.
- enewuser pgagent -1 /bin/bash /home/pgagent
-}