summaryrefslogtreecommitdiff
path: root/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-db/opendbx/opendbx-1.4.6-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-db/opendbx/opendbx-1.4.6-r2.ebuild')
-rw-r--r--dev-db/opendbx/opendbx-1.4.6-r2.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-db/opendbx/opendbx-1.4.6-r2.ebuild b/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
index f3c0607e740f..5c3009011be6 100644
--- a/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
@@ -44,7 +44,21 @@ src_configure() {
use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
- use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+
+ if use oracle ; then
+ # Traditionally, OCI header files are provided in:
+ append-cppflags -I"${ORACLE_HOME}"/rdbms/public
+ # But newer versions merged them with additional SDKs:
+ append-cppflags -I"${ORACLE_HOME}"/sdk/include
+ # Depending on the client package ORACLE_HOME refers to,
+ # we need to find the libraries in varying locations:
+ # - gentoo instantclient has multilib (dev-db/oracle-instantclient)
+ append-ldflags -L"${ORACLE_HOME}"/$(get_libdir)
+ # - vanilla full client lacks multilib (LINUX*_client{,_home}.zip)
+ append-ldflags -L"${ORACLE_HOME}"/lib
+ # - vanilla instantclient lacks libdir (instantclient-*.zip)
+ append-ldflags -L"${ORACLE_HOME}"
+ fi
econf --with-backends="${backends}"
}