summaryrefslogtreecommitdiff
path: root/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
commita1392efe64137262023d92492396ca9156d22396 (patch)
treede438b2711c7697c4597fb04f07e988586f34233 /dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild')
-rw-r--r--dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild b/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild
new file mode 100644
index 000000000000..2b7374017ca9
--- /dev/null
+++ b/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake-utils
+
+DESCRIPTION="MySQL database connector for C++ (mimics JDBC 4.0 API)"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/cpp/"
+URI_DIR="Connector-C++"
+SRC_URI="https://dev.mysql.com/get/Downloads/${URI_DIR}/${P}-src.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+legacy libressl"
+
+RDEPEND="
+ dev-libs/protobuf:=
+ legacy? (
+ dev-libs/boost:=
+ >=dev-db/mysql-connector-c-6.1.8:=
+ )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-8.0.15-fix-build.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SSL=system
+ -DWITH_JDBC=$(usex legacy ON OFF)
+ )
+
+ cmake-utils_src_configure
+}