summaryrefslogtreecommitdiff
path: root/dev-db/mysql++/mysql++-2.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/mysql++/mysql++-2.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/mysql++/mysql++-2.3.2.ebuild')
-rw-r--r--dev-db/mysql++/mysql++-2.3.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-db/mysql++/mysql++-2.3.2.ebuild b/dev-db/mysql++/mysql++-2.3.2.ebuild
new file mode 100644
index 000000000000..d6bdd7a79dcb
--- /dev/null
+++ b/dev-db/mysql++/mysql++-2.3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="C++ API interface to the MySQL database"
+HOMEPAGE="http://tangentsoft.net/mysql++/"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=virtual/mysql-4.0"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+
+ for i in "${S}"/lib/*.h ; do
+ sed -i \
+ -e '/#include </s,mysql.h,mysql/mysql.h,g' \
+ -e '/#include </s,mysql_version.h,mysql/mysql_version.h,g' \
+ "${i}" || die "Failed to sed ${i} for fixing MySQL includes"
+ done
+}
+
+src_configure() {
+ local myconf
+ # we want C++ exceptions turned on
+ myconf="--enable-exceptions"
+ # give threads a try
+ myconf="${myconf} --enable-thread-check"
+ # not including the directives to where MySQL is because it seems to
+ # find it just fine without
+
+ # force the cflags into place otherwise they get totally ignored by
+ # configure
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ econf ${myconf}
+}
+
+src_install() {
+ default
+ # install the docs and HTML pages
+ dodoc README* CREDITS ChangeLog HACKERS Wishlist
+ dohtml -r doc/html/*
+ rm -r doc/html || die
+ dodoc -r doc/*
+}