summaryrefslogtreecommitdiff
path: root/dev-db/mycli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-18 06:41:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-18 06:41:56 +0000
commit5046e96fa41cb320765bdf30253b2a98c27fe94d (patch)
tree008f8b783fae6f3e251250214a372278cd973c53 /dev-db/mycli
parent6d730aa8064fbab6cc54447b6ed0e60b99c13256 (diff)
gentoo auto-resync : 18:01:2025 - 06:41:55
Diffstat (limited to 'dev-db/mycli')
-rw-r--r--dev-db/mycli/Manifest2
-rw-r--r--dev-db/mycli/mycli-1.29.2.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-db/mycli/Manifest b/dev-db/mycli/Manifest
index 6775f7b95909..f1e417279314 100644
--- a/dev-db/mycli/Manifest
+++ b/dev-db/mycli/Manifest
@@ -1,3 +1,5 @@
DIST mycli-1.27.2.gh.tar.gz 286537 BLAKE2B 7bff978f9a08561c33f5327f13b8b69226e5c735527a607190a3c5d75f091b9f76b8d432e7a3e315ff250995e0baea7f7e0bede17e0b1cc6654939b7ec82b0ae SHA512 fdf0342b0e850b5232c815e73f44f22c7ea162201588681ccf2f4107b84b87f01fff3999a9720fef454239192356f074f47642ddc760af18973a2aaaac4676cd
+DIST mycli-1.29.2.tar.gz 293270 BLAKE2B c50b45f217f9b358334cd28a975e5de7b1f70903bf32ee719e03e067b13df13b856a24b9631d2b37a7ad668a82307b030cce1111f0a2ffe625cf9756680eee31 SHA512 13279ec14a0310323f1e407147749e8c628d9cc60688080e691ccfd9cdffd4d8d840a18b6a81075e08247b8a64a19808fbedf2898ab0b2e80ec2906182f23f28
EBUILD mycli-1.27.2.ebuild 1965 BLAKE2B e9e2eee903dd6ff7ea763901ced695724ddfe707950882f095f5a057219dbf1b1e63b21cee0717d44580613aae60a24fac87b9e54541ebae2854ab7f53caca40 SHA512 276048144af05d33c7a2333e4d30ceb9100038e7f156219e3e68e6405fdddedb0ec2b11cff1a9d1b2fb7b64901410f7a4410cdfaa00ad1d7ff28693435e57d5f
+EBUILD mycli-1.29.2.ebuild 2061 BLAKE2B 8ffd19cf7c6736e32124cfeb126ee66c4df24ea5e5da18f6153584285c31b64e19d08bb2d97aa87dacfa01954ed431412932c517923ee6e54d15f5bc256a08d8 SHA512 d9846a43d659ee1829da1f7b8d0dc7530b8592cad4a801ed49ca4b49ac22f14947aa11646682a1a8e53232396c4eeb5f55e51e4be10c606dee7c0f44f3ccf144
MISC metadata.xml 626 BLAKE2B 754538c528392717c6f22b1988d8d901458eaa053d90fdcc6a96c30408a6f9e661bbd8da4dfd57e8edc71e715028e493d7c3b3994ae7b337556881294c771095 SHA512 1d08dd18cdc6e1ab95e80b5234ed6f64c6b9f69346c86bde183c8bbee1940fd54c6a958b03e9b142dceb6d7e61eae2d47c3c5012a9e368a4ec6617c7539729d5
diff --git a/dev-db/mycli/mycli-1.29.2.ebuild b/dev-db/mycli/mycli-1.29.2.ebuild
new file mode 100644
index 000000000000..dc64bce44339
--- /dev/null
+++ b/dev-db/mycli/mycli-1.29.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
+HOMEPAGE="
+ https://www.mycli.net/
+ https://github.com/dbcli/mycli/
+ https://pypi.org/project/mycli/
+"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ssh"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cli-helpers-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.6[${PYTHON_USEDEP}]
+ <dev-python/prompt-toolkit-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyaes-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pyfzf-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlglot-5.1.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.3.0[${PYTHON_USEDEP}]
+ ssh? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/sshtunnel[${PYTHON_USEDEP}]
+ )
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+EPYTEST_DESELECT=(
+ # Requires a running mysql daemon
+ "test/test_main.py::test_batch"
+ "test/test_main.py::test_execute"
+ "test/test_main.py::test_init"
+ "test/test_special_iocommands.py::test_favorite_query"
+ "test/test_special_iocommands.py::test_watch"
+ "test/test_tabular_output.py::test_sql_output"
+)
+
+EPYTEST_IGNORE=(
+ # Requires a running mysql daemon
+ "test/test_sqlexecute.py"
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ default
+
+ # Relax sqlparse requirement, 0.5.0 didn't have major API changes that would necessitate this restriction.
+ # bug #930690
+ sed -i -e '/sqlparse/ s/,<0.5.0//' pyproject.toml || die
+}