summaryrefslogtreecommitdiff
path: root/dev-db/influx-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-db/influx-cli
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-db/influx-cli')
-rw-r--r--dev-db/influx-cli/Manifest4
-rw-r--r--dev-db/influx-cli/influx-cli-2.7.3.ebuild27
-rw-r--r--dev-db/influx-cli/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-db/influx-cli/Manifest b/dev-db/influx-cli/Manifest
new file mode 100644
index 000000000000..cb7973087b5e
--- /dev/null
+++ b/dev-db/influx-cli/Manifest
@@ -0,0 +1,4 @@
+DIST influx-cli-2.7.3-deps.tar.xz 52915924 BLAKE2B 38ca630eb4445dfdd66ed47362cbad220e727c8ddab64eb262e4859577155038650e5d14fcdc6fd8f44c541db07d1b79503c7d9ec5fdd52595198293edf3850e SHA512 c2fa4b7d5d744a85de11f97e3172c9d51b2c1c7b2e31d35fbd15a6ba2b6c12cd4d265216ced0bd27d150d5d3ee619e7d972b67c63cfdbdfdfb69d84d966d881c
+DIST influx-cli-2.7.3.tar.gz 442354 BLAKE2B 3c69e6a2510a4b82830134b930ebc62446848f19cad302f35796853cebd53002963a2d9015512dbf60a4a24e86f237af1ce62c698231150a66331cd8718f2c69 SHA512 d2ffd56c7a1dee24e48afdf487e79b3f125f897fe1c642cccf64a9544134dd6692ebd40415624418597341c16c1afbd444b949c9e3d1bb825ebed5e3f8392dfa
+EBUILD influx-cli-2.7.3.ebuild 600 BLAKE2B 4219f97ec590afddc9f9204561083ea9f06b64cf3675057b0c23e3eff07141304d06dea2bc24f4e4cdce70d583a7e8d8a849efa7d4898685aa43df8d4c3d7f1c SHA512 d4ea5df49c99dc20cf7609ab17d9411bf7a2f21672de471777d6c679fe98efe86cec2119389575654eb7bcb01c724c693c442ee2b717e001a5e6555f53a390cf
+MISC metadata.xml 335 BLAKE2B ccdc9654f7819519bea209895c0a001e37c8297a7de8a55e283ab6ba9427fa4838c04f2d93f303b9d510e72538d076b7c768689be13ce9a384ab645c41cdf25f SHA512 9d5fafd31f2aa729643aa0c2535a0d2f35019706ae246fe5b1d85a388bdfb006a676853a29ea601e042fd39dcb6a4007d94176793d79eb50d9ba632e3c11aa5e
diff --git a/dev-db/influx-cli/influx-cli-2.7.3.ebuild b/dev-db/influx-cli/influx-cli-2.7.3.ebuild
new file mode 100644
index 000000000000..32cb6d38589f
--- /dev/null
+++ b/dev-db/influx-cli/influx-cli-2.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+MY_PV="${PV/_rc/-rc.}"
+
+DESCRIPTION="The command line for influxdb"
+HOMEPAGE="https://github.com/influxdata/influx-cli"
+
+SRC_URI="https://github.com/influxdata/influx-cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT=" test"
+
+src_compile() {
+ unset LDFLAGS
+ emake
+}
+
+src_install() {
+ dobin bin/$(go env GOOS)/$(go env GOARCH)/influx
+}
diff --git a/dev-db/influx-cli/metadata.xml b/dev-db/influx-cli/metadata.xml
new file mode 100644
index 000000000000..1d3caf78c06f
--- /dev/null
+++ b/dev-db/influx-cli/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">influxdata/influx-cli</remote-id>
+ </upstream>
+</pkgmetadata>