summaryrefslogtreecommitdiff
path: root/dev-db/gqlplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-db/gqlplus
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-db/gqlplus')
-rw-r--r--dev-db/gqlplus/Manifest3
-rw-r--r--dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch19
-rw-r--r--dev-db/gqlplus/gqlplus-1.16.ebuild11
3 files changed, 29 insertions, 4 deletions
diff --git a/dev-db/gqlplus/Manifest b/dev-db/gqlplus/Manifest
index 218d06a27ce9..3c82cbe4b124 100644
--- a/dev-db/gqlplus/Manifest
+++ b/dev-db/gqlplus/Manifest
@@ -1,3 +1,4 @@
+AUX gqlplus-1.16-ncurses-tinfo.patch 485 BLAKE2B c5a38640cd4a1b072fc0f966095041b9ae463e6a2c577a822e40bd899f061f11b42b4c0bb8eca4a2ff9064251a69bfef508c8b63b31953da45061e801b337f17 SHA512 4b9fe6e489d12e021384979bc659a75ad60f704ca485320893d42326aece16720c8d02268703b3bc8b45527197dbbe85cbac9d7ae9133ff350718b874abb4382
DIST gqlplus-1.16.tar.gz 2128428 BLAKE2B 5d2ad6cd58d7a5e0e6ce0d54301d70ad452d34a9636ce1f831d1b6d1de3bbc0ebce3d92ed15c2b8da60107d49c56c306543c768c0ef3534f34d2d545b80c43d7 SHA512 e9d7685e4db741db8232f7ba7a05df59042d0cafe198060adcd37aea2d3878e785eacb1f7b72fcb154558d1be8c619818dbeceffaefb75e372a18ed23e234512
-EBUILD gqlplus-1.16.ebuild 752 BLAKE2B 68f4fcc80d2884c2c79d576191316ba43135f2f310050ce6226fa7ac0645159624afe387586081533f29434615c1f48748a924d0a07680e506b132451e30765d SHA512 629af9bb7de9b883ce1c3e6a47c7100ac875302531de6fbdc9d84ccf19770a3af6e481f34e41fa7324f95ba06c554225db265d37fdfce63af2320c535f70e64e
+EBUILD gqlplus-1.16.ebuild 806 BLAKE2B 0e670ae099780beda48b434a2f6e13553c95316ac28c84faccdc3b36dfb2396f9713b25eca594672f03b8884fd324dc2f032b00d8df37424521a2ca1156b209d SHA512 7d5b310253539b0def3d8540115d1796467057968ea9ef175cb71885e54e539efb69fe613e37ace4e8be910b1e803c4f0212b71750c9d4b55c1cabca2b1af618
MISC metadata.xml 620 BLAKE2B 82537c625dbd12eca6562acf5605a5b3b6b1841dd946d2f5dd17a1730bb340f49837f3bea3c9ea6f830abd4c0ecbc3751d218a8daf843f65ca4bb292a5a355be SHA512 8ce9a86e99c4198a246b149f5a526f0cf70ea9e75d3e97bc643520c9377136e83ca56ac47869ae0b62f021dd28da6745204c7c12a52a82e996949b4a796086ce
diff --git a/dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch b/dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch
new file mode 100644
index 000000000000..e39085e0daba
--- /dev/null
+++ b/dev-db/gqlplus/files/gqlplus-1.16-ncurses-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,14 +4,6 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+-AC_CHECK_LIB(ncurses, tgetnum,,
+-[
+- echo "The required library ncurses not found - aborting."
+- exit
+-],)
+-AC_CHECK_LIB(readline, tputs,,
+-[
+- echo "The required library readline not found - aborting."
+- exit
+-],)
++AC_SEARCH_LIBS([tgetnum], [ncurses tinfo], , AC_MSG_ERROR([need ncurses]), [])
++AC_CHECK_LIB(readline, tputs, , AC_MSG_ERROR([need readline]), [])
+ AC_OUTPUT(Makefile)
diff --git a/dev-db/gqlplus/gqlplus-1.16.ebuild b/dev-db/gqlplus/gqlplus-1.16.ebuild
index a3aa8f209869..b21f38c84694 100644
--- a/dev-db/gqlplus/gqlplus-1.16.ebuild
+++ b/dev-db/gqlplus/gqlplus-1.16.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools
DESCRIPTION="a front-end for Oracle program sqlplus with command-line editing"
-HOMEPAGE="https://sourceforge.net/projects/gqlplus/"
+HOMEPAGE="https://gitlab.com/jessp011/gqlplus"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -17,12 +17,17 @@ IUSE=""
DEPEND="sys-libs/readline:*"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-ncurses-tinfo.patch )
+
src_prepare() {
+ default
+
# don't use packaged readline and old version containing it
rm -Rf readline gqlplus-1.15
# maintainer can't seem to get versioning right
sed -i '/^#define VERSION/s/"[^"]\+"/"'"${PV}"'"/' gqlplus.c || die
sed -i '/^AC_INIT/s/\[[1-9.]\+\]/['"${PV}"']/' configure.ac || die
+
eautoreconf
}