summaryrefslogtreecommitdiff
path: root/dev-db/cdb/cdb-0.75-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-db/cdb/cdb-0.75-r4.ebuild
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-db/cdb/cdb-0.75-r4.ebuild')
-rw-r--r--dev-db/cdb/cdb-0.75-r4.ebuild41
1 files changed, 23 insertions, 18 deletions
diff --git a/dev-db/cdb/cdb-0.75-r4.ebuild b/dev-db/cdb/cdb-0.75-r4.ebuild
index 73ca328b0351..6f6e1be87205 100644
--- a/dev-db/cdb/cdb-0.75-r4.ebuild
+++ b/dev-db/cdb/cdb-0.75-r4.ebuild
@@ -1,54 +1,59 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="8"
inherit toolchain-funcs
DESCRIPTION="Fast, reliable, simple package for creating and reading constant databases"
-HOMEPAGE="http://cr.yp.to/cdb.html"
-SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
+HOMEPAGE="https://cr.yp.to/cdb.html"
+SRC_URI="https://cr.yp.to/${PN}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
-DEPEND="!dev-db/tinycdb"
-RDEPEND="${DEPEND}"
+RDEPEND="!dev-db/tinycdb"
+DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${P}-errno.diff
- "${FILESDIR}"/${P}-stdint.diff
+ "${FILESDIR}"/${PN}-errno.patch
+ "${FILESDIR}"/${PN}-inline.patch
+ "${FILESDIR}"/${PN}-stdint.patch
)
+DOCS=( CHANGES README TODO VERSION )
src_prepare() {
default
- sed -i -e 's/head -1/head -n 1/g' Makefile \
- || die "sed Makefile failed"
+ sed -i \
+ -e "s/head -1/head -n 1/g" \
+ -e "s/ar /$(tc-getAR) /" \
+ -e "s/ranlib /$(tc-getRANLIB) /" \
+ Makefile
}
src_configure() {
- echo "$(tc-getCC) ${CFLAGS} -fPIC" > conf-cc || die
- echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
- echo "${EPREFIX}/usr" > conf-home || die
+ echo "$(tc-getCC) ${CFLAGS} -fPIC" >conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" >conf-ld || die
+ echo "${EPREFIX}/usr" >conf-home || die
}
src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest
+ dobin ${PN}{dump,get,make{,-12,-sv},stats,test}
# ok so ... first off, some automakes fail at finding
# cdb.a, so install that now
dolib.a *.a
-
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym cdb.a /usr/$(get_libdir)/libcdb.a
+ dosym ${PN}.a /usr/$(get_libdir)/lib${PN}.a
# uint32.h needs installation too, otherwise compiles depending
# on it will fail
- insinto /usr/include/cdb
- doins cdb*.h buffer.h alloc.h uint32.h
+ insinto /usr/include/${PN}
+ doins ${PN}*.h {alloc,buffer,uint32}.h
- dodoc CHANGES FILES README SYSDEPS TODO VERSION
+ einstalldocs
}