summaryrefslogtreecommitdiff
path: root/dev-db/barman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-db/barman
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-db/barman')
-rw-r--r--dev-db/barman/Manifest4
-rw-r--r--dev-db/barman/barman-2.12.ebuild44
-rw-r--r--dev-db/barman/metadata.xml4
3 files changed, 50 insertions, 2 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
index 0efe71566c4f..efed6f9b7b99 100644
--- a/dev-db/barman/Manifest
+++ b/dev-db/barman/Manifest
@@ -1,3 +1,5 @@
DIST barman-2.10.tar.gz 1247335 BLAKE2B 79bfa4ff6ee587464a18c48b9db110fe100b9f5b1439c21b522e7f5a14a520d247023ca893e2920278cb2170e9daa165f4447b4adff3e09d83cf53c2a9d32bc6 SHA512 64e9386603158bfe19723ec273f8fb3e6856d76315a3e3c31ef489fcb8caaa44a019fff6087dd3d8810661ca8c613552680e5a10e9d673ef96962340dd12dd6a
+DIST barman-2.12.tar.gz 1370978 BLAKE2B 2b44e153addab3fca7dbf572b03b2e22fe18f0960d98048aa145c64552a0de4cea977c423c268bfb9b822e44aaead3572ee350053049ab5459cc022d976eb4d0 SHA512 b4b479a03e5b770ba783af1d5645f6be2a19e2427cb58c6d9dfc6389240d4eeeec85401caa59c0d837a70f1cf67c0edbdb1539ecbd2f3de86285a122fc184320
EBUILD barman-2.10.ebuild 678 BLAKE2B d69e49b5eb7cf4f2d07b628c44616c53cdf0bc28d7698c405421bb1d217bfbcad4cc21c9988032b9d80ca0f77f84689f14ade79c3453d31f0471ff851cb21727 SHA512 aeabd828660aec0563af89aa44d1739eed1c70860833a2284dd324fd64e1ef9330f330bc03dfd0b7d7200f800718342823a57376c482a198bee89696eaf6ce73
-MISC metadata.xml 326 BLAKE2B e34e2bc75606ca796fde6cb82ddcc8993aa093c76a95cd36d1b5ecea0109f301636f5ff5217da2216f029e4891d95a23225f8a5d7ac3fd63c36a3876c70ebd89 SHA512 c0fd87ba5960595461b98161bc9debc37bd5f9665461486845900929854a9b27954020d234688abd9c4589a4066d0185bd11ad53a96551b5399f0025acde4ed1
+EBUILD barman-2.12.ebuild 1073 BLAKE2B 7e9e6d6e804bd7238941caf8edfcb45b18ca8b9d6e4624ca2b0b0e60648f07cd58a7f23a788d517b07afeb1d5460e37106f02ea56b77259dafb92e611edd39ae SHA512 fa1b68478b5942a6172b7c526d3f9bf971ced5d53a96703c945350731e16dd9910d774f514f9dcd933d603068ea3ab2ecdd4f4cdffc0e3b5ee77935c3df23ad9
+MISC metadata.xml 451 BLAKE2B f3a0a41709a89527881547557ae78094174f23499291f5a0509c5b055036847e9299cdb357eba6a5a2ae4c1049d5fb2cdcf1478939213118012c1478d09a90c6 SHA512 62d28dd86e17b41598a8d0c08ca404067ebad8430325e68a993878acc081dd1b5d0b3af04f43eee0de1a4df237a327ece4c18a358e4ae7104a2a0e6d14dbf6c8
diff --git a/dev-db/barman/barman-2.12.ebuild b/dev-db/barman/barman-2.12.ebuild
new file mode 100644
index 000000000000..ce74beef1454
--- /dev/null
+++ b/dev-db/barman/barman-2.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}
diff --git a/dev-db/barman/metadata.xml b/dev-db/barman/metadata.xml
index 37e0d90ffaf5..d07f282d3af4 100644
--- a/dev-db/barman/metadata.xml
+++ b/dev-db/barman/metadata.xml
@@ -6,6 +6,8 @@
<name>Patrick Lauer</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">downloads</remote-id>
+ <remote-id type="github">2ndquadrant-it/barman</remote-id>
+ <remote-id type="sourceforge">pgbarman</remote-id>
+ <bugs-to>https://sourceforge.net/p/pgbarman/tickets/</bugs-to>
</upstream>
</pkgmetadata>