summaryrefslogtreecommitdiff
path: root/dev-db/barman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/barman
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/barman')
-rw-r--r--dev-db/barman/Manifest7
-rw-r--r--dev-db/barman/barman-2.1.ebuild26
-rw-r--r--dev-db/barman/barman-2.3.ebuild26
-rw-r--r--dev-db/barman/barman-2.4.ebuild26
-rw-r--r--dev-db/barman/metadata.xml11
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
new file mode 100644
index 000000000000..7a43e9440e34
--- /dev/null
+++ b/dev-db/barman/Manifest
@@ -0,0 +1,7 @@
+DIST barman-2.1.tar.gz 240437 BLAKE2B 6981049812b520c2605c49e5c7baed5cf350eb386114bf80f3ca2d1cd3abdc9b7d55329f4b8de42b6a47acd7d7e7f925b2c3cf7da1e95393ba3d3c7df938f262 SHA512 385e74c8dcd20d6ad46f6a5a0520cfa47a597395acd433a570ca062ee2834a8b75101fc9a04b19dd312373e4a0b017c90826f7fbeb4f32d8c59313d8b79af1e1
+DIST barman-2.3.tar.gz 255500 BLAKE2B ae84ceade48faf6c65b1d056a7a5b635e5af53f6fa17d6165676e486286effe144125078f84fe6861d948f5b6d568d547ac3258612c95f5cfd5a5e3160197c5c SHA512 c7885ae4940fc990e3368bc654bfe6924fe36f66e6549d3f263a2f23ead2743b2a9ececf55e393ef3105cdf7fc2f38e491895d8e6135e95372eff9eb0d0bfa69
+DIST barman-2.4.tar.gz 997651 BLAKE2B 34c412752d6f0a8bcaa11e3d4538b6116d980f8c3c04bfd9c6ef997f496c4f9497175349b0d0574673a91c14ffab1469d8a988077c7198a2405af680c8205ca6 SHA512 ef316de7cae7f41d95894892b260e1cc67f62866c6feaf03acd96391ab07d9eb27ea7fd6cb472743cbd56658dde24718ac0892ba2280706098f4bdd14b5674d1
+EBUILD barman-2.1.ebuild 643 BLAKE2B 0e3d0ce0899f8cd31c4e73e7b00331d3b8b32ab59e17b3532dcf40a457037c3d1e8fdbd690a8f629c8d9058bac5cf1d887d443d9ca2a31719edf2f102d77b053 SHA512 b3d6eaa4b329cc5fad38eb34d4e96bd65c57f7deba8ca5cd53aacb6b03b57b91752c5c0fda10cf14149904481200b979906d3066496b09de0889ff803684e9bd
+EBUILD barman-2.3.ebuild 643 BLAKE2B 0e3d0ce0899f8cd31c4e73e7b00331d3b8b32ab59e17b3532dcf40a457037c3d1e8fdbd690a8f629c8d9058bac5cf1d887d443d9ca2a31719edf2f102d77b053 SHA512 b3d6eaa4b329cc5fad38eb34d4e96bd65c57f7deba8ca5cd53aacb6b03b57b91752c5c0fda10cf14149904481200b979906d3066496b09de0889ff803684e9bd
+EBUILD barman-2.4.ebuild 658 BLAKE2B 574b4ccc4a4c4bc66777e4b25030eed521d627dc02605efd7083b1ff0e1766ece23e0a5d039e77c0d78c57728ab1384cf656b7f20d606e77bcd4ecc9d3343d9c SHA512 bde0befc55a846395a71e0966e6a0a290707c71d169b26299f155c4037d9785c74ab91592666c0da0098b207d8d8575c6ef23725c9299c4b1b73fc73f2058003
+MISC metadata.xml 326 BLAKE2B e34e2bc75606ca796fde6cb82ddcc8993aa093c76a95cd36d1b5ecea0109f301636f5ff5217da2216f029e4891d95a23225f8a5d7ac3fd63c36a3876c70ebd89 SHA512 c0fd87ba5960595461b98161bc9debc37bd5f9665461486845900929854a9b27954020d234688abd9c4589a4066d0185bd11ad53a96551b5399f0025acde4ed1
diff --git a/dev-db/barman/barman-2.1.ebuild b/dev-db/barman/barman-2.1.ebuild
new file mode 100644
index 000000000000..f41587cacf79
--- /dev/null
+++ b/dev-db/barman/barman-2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+
+HOMEPAGE="http://www.pgbarman.org"
+SRC_URI="http://downloads.sourceforge.net/project/pgbarman/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]"
+DEPEND=""
diff --git a/dev-db/barman/barman-2.3.ebuild b/dev-db/barman/barman-2.3.ebuild
new file mode 100644
index 000000000000..f41587cacf79
--- /dev/null
+++ b/dev-db/barman/barman-2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+
+HOMEPAGE="http://www.pgbarman.org"
+SRC_URI="http://downloads.sourceforge.net/project/pgbarman/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]"
+DEPEND=""
diff --git a/dev-db/barman/barman-2.4.ebuild b/dev-db/barman/barman-2.4.ebuild
new file mode 100644
index 000000000000..f4ffbef2a9cb
--- /dev/null
+++ b/dev-db/barman/barman-2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+
+HOMEPAGE="http://www.pgbarman.org"
+SRC_URI="http://downloads.sourceforge.net/project/pgbarman/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]"
+DEPEND=""
diff --git a/dev-db/barman/metadata.xml b/dev-db/barman/metadata.xml
new file mode 100644
index 000000000000..37e0d90ffaf5
--- /dev/null
+++ b/dev-db/barman/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">downloads</remote-id>
+ </upstream>
+</pkgmetadata>