summaryrefslogtreecommitdiff
path: root/dev-db/barman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-db/barman
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-db/barman')
-rw-r--r--dev-db/barman/Manifest4
-rw-r--r--dev-db/barman/barman-2.12-r1.ebuild (renamed from dev-db/barman/barman-2.12.ebuild)6
-rw-r--r--dev-db/barman/barman-2.19.ebuild44
3 files changed, 50 insertions, 4 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
index b2d872531112..120751148496 100644
--- a/dev-db/barman/Manifest
+++ b/dev-db/barman/Manifest
@@ -1,3 +1,5 @@
DIST barman-2.12.tar.gz 1370978 BLAKE2B 2b44e153addab3fca7dbf572b03b2e22fe18f0960d98048aa145c64552a0de4cea977c423c268bfb9b822e44aaead3572ee350053049ab5459cc022d976eb4d0 SHA512 b4b479a03e5b770ba783af1d5645f6be2a19e2427cb58c6d9dfc6389240d4eeeec85401caa59c0d837a70f1cf67c0edbdb1539ecbd2f3de86285a122fc184320
-EBUILD barman-2.12.ebuild 1073 BLAKE2B 7e9e6d6e804bd7238941caf8edfcb45b18ca8b9d6e4624ca2b0b0e60648f07cd58a7f23a788d517b07afeb1d5460e37106f02ea56b77259dafb92e611edd39ae SHA512 fa1b68478b5942a6172b7c526d3f9bf971ced5d53a96703c945350731e16dd9910d774f514f9dcd933d603068ea3ab2ecdd4f4cdffc0e3b5ee77935c3df23ad9
+DIST barman-2.19.tar.gz 1423229 BLAKE2B db316bad10774ff5825af7409ecc69cd502fe447dd91efc52c04ae23d8e5c21e682fcde351b23dea437817d6207765a6cba355399aea0c5799b0f34be55ee524 SHA512 042912aac1e02994fbbe270f9bf6f4340b9b7ba5b1fdb5d588bdf95098a970ed398e002d1d56731f9b96c8bd0c7e0b71463ab6c08517ce3c1f2c77d1a92618ff
+EBUILD barman-2.12-r1.ebuild 1071 BLAKE2B c1aeb0559545350da1c2afc671280c5a04571980d1c7019b6b0d6a64e926e15395609840c793b05d896727ea48dd9e120ba9594edebfa869a0ca88d91d72deb0 SHA512 80c2c19a626e010bdb24d2ffe2aff41e7041d506e04438c1797af2227e153b158d8ff75f46548e2d8c57739ee22fca94787779668653fe6c84ffef714fcc68ef
+EBUILD barman-2.19.ebuild 1072 BLAKE2B c6b5bd7c1feedf5763aa088a9d4b72f48b8b1cd8eeea8c04698d4a273fef19e84dc70afaff6b1e185a4ecfe15660564ec9bcfb9e2fa13e5a1e958975deb3bd5f SHA512 65e10fb4b81593de8c2c5a09f8dcb98f99367b9577e89bcf07faa03e5dad754e75e036815faaed750ad0c1aef4d1a2498985fe75d273a110e5c8c3e86abeef30
MISC metadata.xml 452 BLAKE2B 21fa365e3d6c53cca2a4f18f46801ddefb86f1f5c0f257d4090ad4209dfda27e041506055c5e102ef193ea61b8ddb4e0887d9387acd4cb4986eb017e44138d7c SHA512 630b4513af924c08574beabcad91e91dc6db5713b32558fed35c45a384439c3db54e5c97bf080224321a606a250ef780b88b7667d0227b72acced29325d0091f
diff --git a/dev-db/barman/barman-2.12.ebuild b/dev-db/barman/barman-2.12-r1.ebuild
index ce74beef1454..44e095f92d0f 100644
--- a/dev-db/barman/barman-2.12.ebuild
+++ b/dev-db/barman/barman-2.12-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/boto3[${PYTHON_USEDEP}]
dev-python/argh[${PYTHON_USEDEP}]
- >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/argcomplete[${PYTHON_USEDEP}]
net-misc/rsync
diff --git a/dev-db/barman/barman-2.19.ebuild b/dev-db/barman/barman-2.19.ebuild
new file mode 100644
index 000000000000..f3cfc26cec01
--- /dev/null
+++ b/dev-db/barman/barman-2.19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}