summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
commit4464bf26d93bdcc80e0b1330fe9c9caef26b34fc (patch)
tree62f9e9438bf700cf277191db5d7c3a641bc972dc /dev-cpp
parent8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (diff)
gentoo auto-resync : 09:03:2024 - 01:07:53
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin14611 -> 14965 bytes
-rw-r--r--dev-cpp/frugally-deep/Manifest3
-rw-r--r--dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild22
-rw-r--r--dev-cpp/frugally-deep/metadata.xml16
-rw-r--r--dev-cpp/functional-plus/Manifest3
-rw-r--r--dev-cpp/functional-plus/functional-plus-0.2.22.ebuild50
-rw-r--r--dev-cpp/functional-plus/metadata.xml16
7 files changed, 110 insertions, 0 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index c3ab4c394223..d6b8a40d50e1 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/frugally-deep/Manifest b/dev-cpp/frugally-deep/Manifest
new file mode 100644
index 000000000000..2175e3f68f2a
--- /dev/null
+++ b/dev-cpp/frugally-deep/Manifest
@@ -0,0 +1,3 @@
+DIST frugally-deep-0.15.30.tar.gz 212149 BLAKE2B 49d73cc09617de4b8344bd7010c1f47397896b0c5cf5b52c95dd2b4c4c861609642d84ba65650a2819cb58459b9a74264b5ca38856db967d6d7988cb55346498 SHA512 ec31a174a1a13d572d7cfce4a1773964cc185c1acaf91250bc8038cd9eba77f864fe9fd592a39648de8c620f02375142344f70c9663613ab1b406df1c68e6cb1
+EBUILD frugally-deep-0.15.30.ebuild 480 BLAKE2B 086f8172431b790fa863d215c12b61be048adfc906758301fb04804bb56ba5ddcd485d8b01adf62cd247ded1967b3fd9a1329b944555423aa90bdf9602d6bf84 SHA512 f75865737244d10108df0670da9812f1a2d148af52f94e070753c814c59a8e8b00ea1bf9d653cd13a3535f891753b91702519165fed9e62c78ff3e7207ad755c
+MISC metadata.xml 553 BLAKE2B 5c215309b135766e2d6e8a23fc688e493077af1a401587eac2574160486405ad10d6ca9054277b8c4ac2752aaccb4d9a5fa257e95bf2b5d40832fa62a23c10eb SHA512 089d98426c099af8a8cf4e6a98b30f4a1b0e12cbdf6d7c5f5151496156209a4ed9436b5f3cf136781af6a94e2260d5147f7fa75ae4bb51a238b288ecaa41eb6e
diff --git a/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild b/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild
new file mode 100644
index 000000000000..10423b3cb2a8
--- /dev/null
+++ b/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only library for using Keras models in C++"
+HOMEPAGE="https://github.com/Dobiasd/frugally-deep"
+SRC_URI="https://github.com/Dobiasd/frugally-deep/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-cpp/functional-plus
+ dev-cpp/eigen
+ dev-cpp/nlohmann_json
+"
+
+RDEPEND="${DEPEND}"
diff --git a/dev-cpp/frugally-deep/metadata.xml b/dev-cpp/frugally-deep/metadata.xml
new file mode 100644
index 000000000000..f7dc7eda7676
--- /dev/null
+++ b/dev-cpp/frugally-deep/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Dobiasd/frugally-deep/issues</bugs-to>
+ <remote-id type="github">Dobiasd/frugally-deep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/functional-plus/Manifest b/dev-cpp/functional-plus/Manifest
new file mode 100644
index 000000000000..be9f895678b8
--- /dev/null
+++ b/dev-cpp/functional-plus/Manifest
@@ -0,0 +1,3 @@
+DIST functional-plus-0.2.22.tar.gz 282821 BLAKE2B dd32e0c518d3b18dd7f31498579edb05cd8a73108c4720db560b48931ed50d8a1a970916d517d488188cdfd69d04d2a3bc6dbfe193b5b8adf114ee7a2938208c SHA512 399ff3012efd49e8617a0ae275e72bf13e87380e830f6ceb56f85fcda948d4ef252c5aa48f48f0a4a015874015d6e8ff442ac9395d523b4c946a01c17f2bd1b9
+EBUILD functional-plus-0.2.22.ebuild 1003 BLAKE2B e495c0f252e93d0840fb5e81ef681e94c4edcff5b8bd5c8ad3cd32402f77ccd7b273abc98a1e3495e86236d6f6337439fd77578569969eaf144b9af79e81625e SHA512 ad40320104b3d629ab960bcb08e58addd458f311e6fdcf230e129eba8e5a319326ad6b916ca4095e9fce9bef1b77e3cdb2d3c1c270daf52d80bdd37f65db54b7
+MISC metadata.xml 555 BLAKE2B afee8434dbc625843066f5c296366f671cd0f74a47db16e2d7764845a736d573b0a7da5c161421306ea493ea8e1e697db8cca838433f7e6257c696f364d78ea1 SHA512 f387279a3d8ecd5fa6e40d414ff73e8b8b8c36c28e21158d1f22d050730fee7ed26c3d9248c688a893da1fb8160010b6e14e7d10bc05ac55c161342c0b3fd0ae
diff --git a/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild b/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild
new file mode 100644
index 000000000000..38e0d9137331
--- /dev/null
+++ b/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Dobiasd/FunctionalPlus.git"
+else
+ SRC_URI="https://github.com/Dobiasd/FunctionalPlus/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Functional Programming Library for C++"
+HOMEPAGE="
+ https://www.editgym.com/fplus-api-search/
+ https://github.com/Dobiasd/FunctionalPlus
+"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+
+S="${WORKDIR}/FunctionalPlus-${PV}"
+
+fplus_test_wrapper() {
+ local BUILD_DIR="${WORKDIR}/${P}_build/test"
+ local CMAKE_USE_DIR="${S}/test"
+ $@
+}
+
+src_configure() {
+ cmake_src_configure
+ use test && fplus_test_wrapper cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use test && fplus_test_wrapper cmake_src_compile
+}
+
+src_test() {
+ fplus_test_wrapper cmake_src_test
+}
diff --git a/dev-cpp/functional-plus/metadata.xml b/dev-cpp/functional-plus/metadata.xml
new file mode 100644
index 000000000000..4dbdfbab0058
--- /dev/null
+++ b/dev-cpp/functional-plus/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Dobiasd/FunctionalPlus/issues</bugs-to>
+ <remote-id type="github">Dobiasd/FunctionalPlus</remote-id>
+ </upstream>
+</pkgmetadata>