summaryrefslogtreecommitdiff
path: root/dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 05:33:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 05:33:01 +0100
commit1a256280f70812d1ae23f0ce2a2569291b6609da (patch)
tree76a302e99d339c5c3b0d18ed3f01a983740a03cb /dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild
parent83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (diff)
gentoo auto-resync : 25:09:2022 - 05:33:00
Diffstat (limited to 'dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild')
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild
new file mode 100644
index 000000000000..1ad533f2dae8
--- /dev/null
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.7.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="YAML parser and emitter in C++"
+HOMEPAGE="https://github.com/jbeder/yaml-cpp"
+SRC_URI="https://github.com/jbeder/yaml-cpp/archive/${P}.tar.gz"
+S="${WORKDIR}/yaml-cpp-${P}"
+
+LICENSE="MIT"
+SLOT="0/0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gtest.patch"
+ "${FILESDIR}/${P}-cmake-paths.patch"
+ "${FILESDIR}/${P}-install-paths.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DYAML_BUILD_SHARED_LIBS=ON
+ -DYAML_CPP_BUILD_TOOLS=OFF # Don't have install rule
+ -DYAML_CPP_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}