summaryrefslogtreecommitdiff
path: root/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
deleted file mode 100644
index d7b8d0935b9a..000000000000
--- a/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="C++/Boost Asio based websocket client/server library"
-HOMEPAGE="https://www.zaphoyd.com/websocketpp"
-SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-libs/boost )"
-RDEPEND="dev-libs/boost"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.0-cmake-install.patch
- "${FILESDIR}"/${PN}-0.8.1-boost-1.70.patch
- # disable tests that are timing sensitive
- # https://bugzilla.redhat.com/show_bug.cgi?id=1461069
- "${FILESDIR}"/${PN}-0.8.1-disable-test_transport-test_transport_asio_timers.patch
- # https://github.com/zaphoyd/websocketpp/commit/36b73da8958927f975b3d01a062aa6c0e149d97f
- "${FILESDIR}"/${PN}-0.8.2-fix-boost_find_component.patch
- # https://github.com/zaphoyd/websocketpp/commit/2c355d9ef0f3ed73fa96d0c6c31293086df36d74
- "${FILESDIR}"/${PN}-0.8.2-fix-clang.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CPP11=ON
- -DBUILD_TESTS="$(usex test)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}