summaryrefslogtreecommitdiff
path: root/dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild b/dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
new file mode 100644
index 000000000000..1f3730df214a
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# bug 630450
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-cmake-install.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CPP11="$(usex !boost)"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use examples && DOCS=( examples/ )
+ cmake-utils_src_install
+}