summaryrefslogtreecommitdiff
path: root/dev-cpp/valijson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-cpp/valijson
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-cpp/valijson')
-rw-r--r--dev-cpp/valijson/Manifest3
-rw-r--r--dev-cpp/valijson/files/1.0-fix-macro-typos.patch77
-rw-r--r--dev-cpp/valijson/valijson-1.0.ebuild24
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-cpp/valijson/Manifest b/dev-cpp/valijson/Manifest
index 2d4f0bd11b0a..72f61ef14875 100644
--- a/dev-cpp/valijson/Manifest
+++ b/dev-cpp/valijson/Manifest
@@ -1,3 +1,6 @@
+AUX 1.0-fix-macro-typos.patch 2966 BLAKE2B 5f8307c6a71cd4066a6f68af78e3f35294490688c65fdee7dd3a7d0394de0210a13a784255bba761e408870d9d76691bd6f298e9ecb7c0e7f3b816f71a805742 SHA512 6da572cb86237758708d171452eb8ba88e7f2cda1baecfaf8dd2f674b04de0cdd2d57c9041f517ff472714ff2ad66e66aa4e432931f09bfb00349c1c48b8e6da
DIST valijson-0.7.tar.gz 2060214 BLAKE2B d2e1c58e37213e44d7d6af173691cad3853e87648948c229ea683bfcba8b19256b0230852b0537c2dbdd7084fcf1ac068e320c5f59a69e446610390b82e76474 SHA512 662e53bf1cac4def19792392cda7cbfe2cbadf77b768eb69b2dec693b16f85f32fa2e9b97eae36569cfcc9ac45f1e6338967423cf415d6bcd90372bc49793a2d
+DIST valijson-1.0.tar.gz 721078 BLAKE2B 74f4a061266a6ee8fba9d93b4e1df20dc828d85169f865bdb60ba9f5217ee422324a09788b02b4ddd18a92d906c64863a5bd7c1250f8bdb62fd9f00f3d73c7e7 SHA512 a206954b11e92cbebbebf094e6f0925a270ebd6bec49cbdb7adda5a4cec93587a5a61ebbce105846c3950cf5df74bfdd5f5bb1ffbf73315f45c7a6cda2b77db9
EBUILD valijson-0.7.ebuild 1230 BLAKE2B e3d2621fd12a4700337b07347775250c3766b7f1ae474462813505dad733aa4cee201117695deb98500dfb919fe8b9cc8a0fe5e30e76969f34058c9aee674ed3 SHA512 02e8ddfac46ebb0f2ae4c3563119ba32c13285321b60049eed68ded9b96ead3619fb1b094d80917a1da1fd8e97a0dd52024549996639149dfccf872a19746057
+EBUILD valijson-1.0.ebuild 579 BLAKE2B 34d1a2725f32ad1c35a662f4b7f62f6e9666b4d5f08a92b792ab7e2dbe8b278d65a6de9da85e1343539b294456350dc7e75d8ee92c7032712e9c6267b6a4f5f5 SHA512 e93fb7c8daf1d0a92baae3e9d6d8479ad17e8079559dbcaff00db55670b27442970b703563e3b9b31f5753f7cca1ba4768f68a8001a6346244df16a0fd25c6d3
MISC metadata.xml 498 BLAKE2B 415d770e91c8304ace73ee5ff1ee079d7e1c09c6eeac26123e4ba4615194829a0c8bedfe27e2e803cddb101b30c3bd94b6003523fa0ec849972303b0f37f59e2 SHA512 dfaf020b039378127a159f2f8b66f1488b671817c34b77b01e19f24c117306c88801e26990fc434b4f9c23d1620631cf048ff9c281017135e46c7b7acbbfb8a0
diff --git a/dev-cpp/valijson/files/1.0-fix-macro-typos.patch b/dev-cpp/valijson/files/1.0-fix-macro-typos.patch
new file mode 100644
index 000000000000..f90e88dabe92
--- /dev/null
+++ b/dev-cpp/valijson/files/1.0-fix-macro-typos.patch
@@ -0,0 +1,77 @@
+
+Patch from:
+https://github.com/tristanpenman/valijson/commit/f1ff3518281fe347c97b78384d6bb645dbdd4788
+
+From f1ff3518281fe347c97b78384d6bb645dbdd4788 Mon Sep 17 00:00:00 2001
+From: Austin Haigh <austin.haigh@hach.com>
+Date: Tue, 1 Nov 2022 13:29:16 -0600
+Subject: [PATCH] fix typos in preprocessor macros
+
+---
+ examples/valijson_nlohmann_bundled.hpp | 2 +-
+ include/valijson/utils/boost_json_utils.hpp | 4 ++--
+ include/valijson/utils/nlohmann_json_utils.hpp | 2 +-
+ include/valijson/utils/property_tree_utils.hpp | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/examples/valijson_nlohmann_bundled.hpp b/examples/valijson_nlohmann_bundled.hpp
+index 806f329..915bebb 100644
+--- a/examples/valijson_nlohmann_bundled.hpp
++++ b/examples/valijson_nlohmann_bundled.hpp
+@@ -10561,7 +10561,7 @@ inline bool loadDocument(const std::string &path, nlohmann::json &document)
+ }
+
+ // Parse schema
+-#if VALIJSON_USE_EXCEPTION
++#if VALIJSON_USE_EXCEPTIONS
+ try {
+ document = nlohmann::json::parse(file);
+ } catch (std::invalid_argument const& exception) {
+diff --git a/include/valijson/utils/boost_json_utils.hpp b/include/valijson/utils/boost_json_utils.hpp
+index 1168903..0fbd6c3 100644
+--- a/include/valijson/utils/boost_json_utils.hpp
++++ b/include/valijson/utils/boost_json_utils.hpp
+@@ -20,7 +20,7 @@ inline bool loadDocument(const std::string &path, boost::json::value &document)
+ }
+
+ // Parse schema
+-#if VALIJSON_USE_EXCEPTION
++#if VALIJSON_USE_EXCEPTIONS
+ try {
+ #endif
+ boost::json::error_code errorCode;
+@@ -30,7 +30,7 @@ inline bool loadDocument(const std::string &path, boost::json::value &document)
+ std::cerr << "Boost.JSON parsing error: " << errorCode.message();
+ return false;
+ }
+-#if VALIJSON_USE_EXCEPTION
++#if VALIJSON_USE_EXCEPTIONS
+ } catch (std::exception const & exception) {
+ std::cerr << "Boost.JSON parsing exception: " << exception.what();
+ return false;
+diff --git a/include/valijson/utils/nlohmann_json_utils.hpp b/include/valijson/utils/nlohmann_json_utils.hpp
+index b3cbe20..77e5771 100644
+--- a/include/valijson/utils/nlohmann_json_utils.hpp
++++ b/include/valijson/utils/nlohmann_json_utils.hpp
+@@ -20,7 +20,7 @@ inline bool loadDocument(const std::string &path, nlohmann::json &document)
+ }
+
+ // Parse schema
+-#if VALIJSON_USE_EXCEPTION
++#if VALIJSON_USE_EXCEPTIONS
+ try {
+ document = nlohmann::json::parse(file);
+ } catch (std::invalid_argument const& exception) {
+diff --git a/include/valijson/utils/property_tree_utils.hpp b/include/valijson/utils/property_tree_utils.hpp
+index 2317f12..7438980 100644
+--- a/include/valijson/utils/property_tree_utils.hpp
++++ b/include/valijson/utils/property_tree_utils.hpp
+@@ -24,7 +24,7 @@
+ #include <valijson/utils/file_utils.hpp>
+ #include <valijson/exceptions.hpp>
+
+-#if !VALIJSON_USE_EXCEPTION
++#if !VALIJSON_USE_EXCEPTIONS
+
+ namespace boost {
+
diff --git a/dev-cpp/valijson/valijson-1.0.ebuild b/dev-cpp/valijson/valijson-1.0.ebuild
new file mode 100644
index 000000000000..f8228da04f59
--- /dev/null
+++ b/dev-cpp/valijson/valijson-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only C++ library for JSON Schema validation"
+HOMEPAGE="https://github.com/tristanpenman/valijson"
+SRC_URI="https://github.com/tristanpenman/valijson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-macro-typos.patch
+)
+
+src_install() {
+ # there is no target for installing headers, so do it manually
+ doheader -r include/*
+}