summaryrefslogtreecommitdiff
path: root/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 17:45:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 17:45:56 +0000
commitca04d5f1b74639bc2db1e371abbf0182fc431828 (patch)
tree5e6d2b5341c69d06a6d3e8352c5b8b88a5382302 /dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
parent0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (diff)
gentoo auto-resync : 13:12:2023 - 17:45:55
Diffstat (limited to 'dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild')
-rw-r--r--dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
new file mode 100644
index 000000000000..c239fca55478
--- /dev/null
+++ b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="TOML config file parser and serializer"
+HOMEPAGE="
+https://marzer.github.io/tomlplusplus/
+https://github.com/marzer/tomlplusplus
+"
+SRC_URI="https://github.com/marzer/tomlplusplus/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_lib=true
+ -Dgenerate_cmake_config=true
+ -Duse_vendored_libs=true # for test dependencies, header only and very restrictive version requirements
+ $(meson_use test build_tests)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ local emesontestargs=(
+ 'tests - C'
+ )
+
+ meson_src_test "${emesontestargs[@]}"
+}