summaryrefslogtreecommitdiff
path: root/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
commit2929788def9a92c1eb237eed93fbdb0c02838bbf (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
parentab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (diff)
Revert "gentoo resync : 13.10.2019"
This reverts commit ab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030.
Diffstat (limited to 'dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild')
-rw-r--r--dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild b/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..882c07045372
--- /dev/null
+++ b/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A cross-platform C++ thread pool library (built on top of Boost)"
+HOMEPAGE="http://threadpool.sourceforge.net/"
+MY_PV=${PV//./_}
+MY_P=${PN}-${MY_PV}
+SRC_URI_BASE="mirror://sourceforge/threadpool/threadpool/${PV}%20%28Stable%29"
+SRC_URI="${SRC_URI_BASE}/${MY_P}-src.zip
+ doc? ( ${SRC_URI_BASE}/${MY_P}-doc.zip )"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-libs/boost"
+
+S="${WORKDIR}/${MY_P}-src/${PN}"
+
+DOCS=( README TODO CHANGE_LOG )
+PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
+
+src_compile() {
+ # Do nothing
+ # The makefile just builds the documentation again
+ # Not even any install targets
+ return
+}
+
+src_install() {
+ doheader -r boost
+
+ use doc && HTML_DOCS+=( "${WORKDIR}"/"${MY_P}"-doc/. )
+ einstalldocs
+}