summaryrefslogtreecommitdiff
path: root/dev-cpp/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-cpp/termcolor
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-cpp/termcolor')
-rw-r--r--dev-cpp/termcolor/Manifest3
-rw-r--r--dev-cpp/termcolor/metadata.xml11
-rw-r--r--dev-cpp/termcolor/termcolor-2.0.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/termcolor/Manifest b/dev-cpp/termcolor/Manifest
new file mode 100644
index 000000000000..e06c05629086
--- /dev/null
+++ b/dev-cpp/termcolor/Manifest
@@ -0,0 +1,3 @@
+DIST termcolor-2.0.0.tar.gz 88582 BLAKE2B 3e7a4a99af3586fff103d0de0601e019881745e2921b4750dbf476439138a71120b6513a287c5fe26fd96a9c6115cb82295810d9bea11d0992f48fcd5d0a8d18 SHA512 72dead77fb9f3ff79432b1659b57c3d961a57b46305937acd0c221f5abb016f609dfaf7a9bf508bd7a073338ee604cf55f9915c8e8a76ddfaf6c68bc031e37f9
+EBUILD termcolor-2.0.0.ebuild 655 BLAKE2B fc1e0c68a155af42604134dd6b04d7ee2036ef40e4b1bceba19e92757e9b908b49e14d1e49aed0c7c5f8b7acc28cd57709a1a36d55234362ea9655d86a84edb3 SHA512 261be127774c2f9f3fbdd1d6a4ab8c2869a708fc09dd412474a36868f61bb6da0554d6c58c7b9dca66074b4d105b60e9455fc70349b397936a9adac4c9b67032
+MISC metadata.xml 325 BLAKE2B 48f1d9fd2d9aea47d807bca606e06d275a966e8264dd1aebe6f13b4bc956cc0c3bb805785a4d7d199806f9a00623150a780c490c2fd2fd7f672986c30ab6f592 SHA512 d178afb983241e1abb7dfe4ef928a59ab8093eb66eadc5c72f49516c17f0b1b7c8e28818005bdda92bd6fb03687fa8f1eeeeb530ae6828ef32f49a07dd2867ae
diff --git a/dev-cpp/termcolor/metadata.xml b/dev-cpp/termcolor/metadata.xml
new file mode 100644
index 000000000000..07725c8b4ff7
--- /dev/null
+++ b/dev-cpp/termcolor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ikalnytskyi/termcolor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/termcolor/termcolor-2.0.0.ebuild b/dev-cpp/termcolor/termcolor-2.0.0.ebuild
new file mode 100644
index 000000000000..2b522f5ede05
--- /dev/null
+++ b/dev-cpp/termcolor/termcolor-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A header-only C++ library for printing colored messages to the terminal"
+HOMEPAGE="https://github.com/ikalnytskyi/termcolor https://termcolor.readthedocs.io"
+SRC_URI="https://github.com/ikalnytskyi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# It's just a visual test, nothing automated / no way to detect failure in an ebuild.
+RESTRICT="!test? ( test ) test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTERMCOLOR_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}