summaryrefslogtreecommitdiff
path: root/dev-cpp/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-cpp/termcolor
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-cpp/termcolor')
-rw-r--r--dev-cpp/termcolor/Manifest2
-rw-r--r--dev-cpp/termcolor/termcolor-2.1.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-cpp/termcolor/Manifest b/dev-cpp/termcolor/Manifest
index 22e94db7bf12..c22779ca7a64 100644
--- a/dev-cpp/termcolor/Manifest
+++ b/dev-cpp/termcolor/Manifest
@@ -1,3 +1,5 @@
DIST termcolor-2.0.0.tar.gz 88582 BLAKE2B 3e7a4a99af3586fff103d0de0601e019881745e2921b4750dbf476439138a71120b6513a287c5fe26fd96a9c6115cb82295810d9bea11d0992f48fcd5d0a8d18 SHA512 72dead77fb9f3ff79432b1659b57c3d961a57b46305937acd0c221f5abb016f609dfaf7a9bf508bd7a073338ee604cf55f9915c8e8a76ddfaf6c68bc031e37f9
+DIST termcolor-2.1.0.tar.gz 89041 BLAKE2B 1b3681dcd7dde394737bdc02e8a8ae10c61adfddbb1506e7254c27636a9045bc17ebe45801ecf813c3fc6b3a4bb3ea90bc6246e651105fab2e42b0807fa74339 SHA512 668853a93e1208a08a4ea9ac8db2d9c615cefd0325c35402b767e0b1bf373589507b8eb7685babd5801c1e4f2533db6f4eabfedde365737a4c7c069f00f536d8
EBUILD termcolor-2.0.0.ebuild 709 BLAKE2B 110e2c6d5303cd506ea57ed3602a3476bb4d9cf3dbb2033cd07d8cba20670c0dfb3e2e2eec1950ffbe253f19e115040984ffde6fdc2be02887c1391583854de0 SHA512 b87940816bf018662432cb63410c6d17f570f6e7930fe673c5dde4c31f0f4a7f1d69312f1a289bb7f6b0336a4cbd8cbc7b48d1a298c4c27d967a02806e620ed6
+EBUILD termcolor-2.1.0.ebuild 709 BLAKE2B b9f8bbe40bda7e605e3a698b46135256a7714b596d8483fc6f8e1bcaf8ea8b2822db9dd50ebd4f3cfa90a73f124088c7baf350adbf929c567dcdee91ce86ed50 SHA512 797a4b370de015a1651dcaa3f73fb1751a9d857643d71274ded25aaae7344f027215b9b2af9258003172161e293cd6f3e4860bd550b7dc2790b81edacb14620e
MISC metadata.xml 326 BLAKE2B cbcd28ae3a24dcc44fc1964c88631699f0539af0ee610d852b7d6762634fbf7a69202ecb97707ec270d5a2c434b172601422d524d4798ef85e42cb4e56fd6246 SHA512 bc434944969c93594e6d52a2cf2d222d8b06cd8e21818c40221483e6ada2aa4d2e15471573264264eb4b8fc502f7519f513575a2fb410bd3ffb000b30b035c5a
diff --git a/dev-cpp/termcolor/termcolor-2.1.0.ebuild b/dev-cpp/termcolor/termcolor-2.1.0.ebuild
new file mode 100644
index 000000000000..62b3a7572734
--- /dev/null
+++ b/dev-cpp/termcolor/termcolor-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A header-only C++ library for printing colored messages to the terminal"
+HOMEPAGE="https://github.com/ikalnytskyi/termcolor https://termcolor.readthedocs.io"
+SRC_URI="https://github.com/ikalnytskyi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# It's just a visual test, nothing automated / no way to detect failure in an ebuild.
+RESTRICT="!test? ( test ) test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTERMCOLOR_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/test_termcolor || die
+}