summaryrefslogtreecommitdiff
path: root/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-cpp/sparsehash/sparsehash-2.0.4.ebuild')
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
new file mode 100644
index 000000000000..3f6a91f5fbd6
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/sparsehash/sparsehash/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}