summaryrefslogtreecommitdiff
path: root/dev-cpp/prometheus-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-cpp/prometheus-cpp
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest4
-rw-r--r--dev-cpp/prometheus-cpp/metadata.xml10
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild41
3 files changed, 47 insertions, 8 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index 6a8411785193..ad572a58c980 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,3 +1,5 @@
DIST prometheus-cpp-0.12.2.tar.gz 55191 BLAKE2B f1430cf6b8ca8272c447e8c2a25af5fb0d515389cb1078f8836a9a1f1ba0e26cc43236e9c147219384df40d601b843219acb95ebc46bb1c2fce6d83a86724182 SHA512 9907658939b7956219c3623bd5997f341f4374fbce2ee606bd1d8df820779ed8dc70658a30aafbb47b9af645205c048270b23e701203e13286bc365094a441d3
+DIST prometheus-cpp-0.12.3.tar.gz 55510 BLAKE2B 8a9dffb4608f1d1f141726cf7bec3a19ca9040baca9871ff3aa950aa979b34319e704539ff3f2830a5c145645e9c3c0efc9e9b2c5c534d8b3745aaf1e9426763 SHA512 e8093db6e58d1672fd94daeed94f2c11f663145195bf878e0403973f2f4f62a3f9430cf6de1fc9ac0821b4b323e3faeb96199d450b3d7a04a5dee0e6f94ddc01
EBUILD prometheus-cpp-0.12.2.ebuild 821 BLAKE2B b4a5e9817f4cb65919ad504a6d2bcc53cf41b0cc81bfdda34eaf4b335d6bc9054d7648ebf4a344afc1087239b020f073142994b8ceebc0bf77c9daa1798632e5 SHA512 4377daa3ed659ee16bb0dca9bdce029b5e68650cccce4d4a6eb6b518e8f5bfbf4e08f11779e1a45e0b0c782218b8026b1200302e27459d1b7993f931564760f1
-MISC metadata.xml 987 BLAKE2B a3ee76e524e97e6577b2e71d00cd2eb29821f74230d8b8224497565ddf2e80a7358f37a95948caf1dc3a4213f7e96683a54b10836e83a71e6e5caf78d59a8268 SHA512 cfea74c7e5325514dacc13fc86213bc2c6fe758681168099fa1edb5b49503ffa40b83dc10ba6fdcbbbbe502aa064a6445caa7c07c8f1c82fe177dc574dbd75da
+EBUILD prometheus-cpp-0.12.3.ebuild 820 BLAKE2B ecb1dc2c941fdc12311b5a17a1afefe8cf5304439a483b75b660bd7e12d2cc6e92c181acd1d8c8344145ec1775526ca76a53437bd8d2aaa3f315554f71840da6 SHA512 e07936dcc5f9d2ef4eb16f6123e721d9571a77a4a122eb877e7eca17f05d6de2972a8f55d637da8223fa9981997a8e6e43945dbdc53f08ae74dc3b48b135beb1
+MISC metadata.xml 825 BLAKE2B 0e3dc6f05ff9c5d4c814824752beaa49d4b7617f1e15d6cb00a2ecbe1aba631aaaef1b542b22678ee048c33e39ebf8937bc016a02e9a36e29371950914ff7ef5 SHA512 d00e3ed23db9de8adb96a47d350ebf3cc40d8a1c8751266a4ff1cbbc8b698d20da513415106ad0263c71715e272c430fb9e07d80fc7223de62f7ef85f6dc50cc
diff --git a/dev-cpp/prometheus-cpp/metadata.xml b/dev-cpp/prometheus-cpp/metadata.xml
index 3a50d92cce7b..c001ab6f8b63 100644
--- a/dev-cpp/prometheus-cpp/metadata.xml
+++ b/dev-cpp/prometheus-cpp/metadata.xml
@@ -8,13 +8,9 @@
be collected by Prometheus, but other push/pull collections can be added
as plugins.
</longdescription>
- <maintainer type="person" proxied="yes">
- <email>vilhelm.gray@gmail.com</email>
- <name>William Breathitt Gray</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
</maintainer>
<upstream>
<bugs-to>https://github.com/jupp0r/prometheus-cpp/issues</bugs-to>
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild
new file mode 100644
index 000000000000..dca730a03e41
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ -DGENERATE_PKGCONFIG=ON
+ -DRUN_IWYU=OFF
+ )
+
+ cmake_src_configure
+}