summaryrefslogtreecommitdiff
path: root/dev-cpp/prometheus-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-cpp/prometheus-cpp
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest2
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild41
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index bc95fafb3b89..988746aa078b 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,5 +1,3 @@
-DIST prometheus-cpp-0.13.0.tar.gz 55448 BLAKE2B 5790e74f5bb783070b6928adf9d850dc59ff8507d580a96549e62a2ea9ca1cf5b5de0fb445dd373bbae6da3fdae59d1dbf2eca5e04dc3d6adb58e5c52da1e666 SHA512 d2c6708047cec1998697931d5e9b420dfa513ade9f298761b08ae87a5526cbe64476ebc56793c21d8c3d741e3a4db5ce8d27af1d39b4ca30a45de34f40fdca67
DIST prometheus-cpp-1.0.0.tar.gz 56244 BLAKE2B 51ff199c0cd09367de873310a835b7a4a5893de11a6115b3de8ef142eb12b326ea7498a8adc155f3bbea6389da41eef91b5ef23cb0227ef1d1ceb64e4d7eac2e SHA512 baeb12725dd47b170e1ac94c23b2b18ba8aa11dedd95af7adee8fdf9ddebaddfca1ef75c30b1d65c94e1cfbcba2c41e0f4686f1a1de66beaba7dcd70ab190164
-EBUILD prometheus-cpp-0.13.0.ebuild 827 BLAKE2B db34157d5a96e09bac17e977bf16d678d7e6045baf521efb1270b246744d11bf563d4ee338669dadf09249f5bcf122835963d1118deeb74196b4f861346af611 SHA512 4f02623e6d3b1f2bc90b550cc40c9e424547b7afe7d6f72fe3fe1e0768b82ebe0d15171c07349e3d7bdefbbf29c38efbdf56ec74d8a4a6ec36dc007777d7bb4e
EBUILD prometheus-cpp-1.0.0.ebuild 827 BLAKE2B db34157d5a96e09bac17e977bf16d678d7e6045baf521efb1270b246744d11bf563d4ee338669dadf09249f5bcf122835963d1118deeb74196b4f861346af611 SHA512 4f02623e6d3b1f2bc90b550cc40c9e424547b7afe7d6f72fe3fe1e0768b82ebe0d15171c07349e3d7bdefbbf29c38efbdf56ec74d8a4a6ec36dc007777d7bb4e
MISC metadata.xml 826 BLAKE2B 309447cc55a501661cb9bfa636bc54f7ba6c2ee2aec545b5a1a38fbbeaf7180fdda0c768ff941844a1cb83ce9b5d89520a0a143e5e0f87b86f57ca8aea82bd2f SHA512 7e2fe05bc17e6b40fffe6b75849953ca8dd6970adb38d5e5fa38bd03f9aea38df14ddb675dee70b8930cca4a9ec3c01c2bdf4ed36f4db2c4d5e4152e13ed09f4
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild
deleted file mode 100644
index 07f8033472af..000000000000
--- a/dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Prometheus Client Library for Modern C++"
-HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
-SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="test zlib"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="net-misc/curl
- sys-libs/zlib
- www-servers/civetweb[cxx]"
-DEPEND="${RDEPEND}
- test? (
- dev-cpp/benchmark
- dev-cpp/gtest
- )"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PULL=yes
- -DENABLE_PUSH=yes
- -DENABLE_COMPRESSION=$(usex zlib)
- -DENABLE_TESTING=$(usex test)
- -DUSE_THIRDPARTY_LIBRARIES=OFF
- -DGENERATE_PKGCONFIG=ON
- -DRUN_IWYU=OFF
- )
-
- cmake_src_configure
-}