summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-13 02:23:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-13 02:23:08 +0100
commit4d4b75287f879f15ebdc56b3edd19737b6f936e8 (patch)
treec02f05b73dd6c0a9d8b35dcb57c7eeaab6cfa9bc /dev-cpp/nlohmann_json
parentf8ca23f9f6e4a55e4195e553ca2f3e7dd425f51c (diff)
gentoo auto-resync : 13:08:2022 - 02:23:08
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest3
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild61
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 82e2239d382b..c585a03b8af2 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,4 +1,7 @@
DIST nlohmann_json-3.10.5.tar.gz 7021996 BLAKE2B d4219d2f3168341eb8bd8f84af364e53f6caae67aa080b1ca0479216a98ee0256d5436243273b3c12ccdca904b4b17dbb90cf445fc273424d7dab6d2b95632bc SHA512 4a9d6416f383e76bf95425fc02a4e12c605fcbcae910b704e354396a493454cf8a1ffbecba11f231e020ffd2842908df7e67dbc09f62d1202d40b6815c24cfd2
+DIST nlohmann_json-3.11.2.tar.gz 8097673 BLAKE2B ebb67966739a330e0cfb8495a6eb58e87732655856a6d4e843072ed5e485cafbb8a75d8803859d0365b814deda7429448ecc473de414de4b23d3a3c455dc2511 SHA512 70097c9bcd7a91254acbd41b8b68a6aaa371fc2dd7011f472917f69f1e2d2986155a0339dad791699d542e4a3be44dc49ae72ff73d0ee0ea4b34183296ce19a0
DIST nlohmann_json-testdata-3.0.0.tar.gz 112348454 BLAKE2B f0a47b41805bf1426f612e9a82efea2a3e5b1c15740c1c531d859e60dc5daeb85209b4fe363fd8fb84e3bbf01a2578c74538ba3e769726494047979f5a4d468d SHA512 d9af8419b837c592ec7519cd5772651c761078a9c43cf2a309cee55c323aee0df0c233fb58a07d5ee2e77492ac8b16398de234b387eae037a60e3c9ba5b08891
+DIST nlohmann_json-testdata-3.1.0.tar.gz 115036393 BLAKE2B 809be0728a0b9d007fcc752911bdf6f7e548d6e3ec59871ea2b16d87d8248ca4dd2f681a1d0f82c618463294188ad41d6d965b8bdc39c70fdcf4b939d4121e9c SHA512 db6c411b37f2154f5dd1ed90f4e8fa0907f4a736cd0ff79943bcacf9da422285ff142bb6a7dc6022b236090083166ac1ab197be3f480d8dc50b26a91a9477821
EBUILD nlohmann_json-3.10.5.ebuild 1702 BLAKE2B 786102846dba60718eff3f44d953d22b02393dc0bc9cb809b32eefeee9e1876f4c594a508fce761b4a77f86456561864c45c38bd6606a0df3bad69af4c2bf201 SHA512 12d2bab20d2f6d6c38f4bbdf4459fa4c7a52d0ad31da7958b6076c7776e0c4e3a6aa70e72e74d0873e3a93f80568610c858f3b7c2f2a20943c31d041c23d1846
+EBUILD nlohmann_json-3.11.2.ebuild 1728 BLAKE2B d4e214212938c10d86fa5cac215a35e93c7095eb30d965194e9501b9931bafce6e3679948c2cb2a7e5d8fcf414575b122d0af1e0ad571f1dd3ef99ab594a6cce SHA512 a08a08909f6f974252cca7f2018576d949356934e6dbaa79acfc2d7863cc4ce7e6a99c2fc83e31985b67011ae3d9d1d4aed6586588a356e876260e04a3f300e4
MISC metadata.xml 338 BLAKE2B c5eb95ba7048308eab4753ea01c015781ce85db42d2e50f8ed9e3f7fb6945cfb8b90f5b3216799ad53137ceef6eae4636eea482e86206b19589ddf2e42caaaa1 SHA512 4198102ff79678a8e9be9146fc97991b1b205be3d34ebaece3dcab46a36ee5af904f463fcd0dc2a88fb362aa7a81e8d713af7b55db594a7069efc0276c94ff49
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
new file mode 100644
index 000000000000..c631bc6644a9
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+#DOCS_BUILDER="mkdocs"
+# Needs unpackaged plantuml-markdown too
+# ... but plantuml (Python bindings anyway) need network access to generate bits at runtime.
+#DOCS_DEPEND="dev-python/mkdocs-material-extensions dev-python/mkdocs-minify-plugin"
+#DOCS_DIR="doc/mkdocs"
+inherit cmake
+
+# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
+TEST_VERSION="3.1.0"
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="
+ https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
+S="${WORKDIR}/json-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( ChangeLog.md README.md )
+
+src_prepare() {
+ if use test ; then
+ ln -s "${WORKDIR}"/json_test_data-${TEST_VERSION} "${S}"/json_test_data || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Tests are built by default so we can't group the test logic below
+ local mycmakeargs=(
+ -DJSON_MultipleHeaders=ON
+ -DJSON_BuildTests=$(usex test)
+ )
+
+ # Define test data directory here to avoid unused var QA warning, bug #747826
+ use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/tests || die
+
+ # Skip certain tests needing git per upstream
+ # https://github.com/nlohmann/json/issues/2189
+ local myctestargs=(
+ "-LE git_required"
+ )
+
+ cmake_src_test
+}