summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-cpp/nlohmann_json
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest3
-rw-r--r--dev-cpp/nlohmann_json/metadata.xml11
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
new file mode 100644
index 000000000000..de2a5ba7997b
--- /dev/null
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -0,0 +1,3 @@
+DIST nlohmann_json-3.5.0.tar.gz 114796008 BLAKE2B 94caa0374be1d38230cb13b8cd9deb3da04e4b81d361ce6baf54c1bad231945a94df74683a31660dc98413dbf23ea7596c6ed1da9cda9e02add7d7c6568973e3 SHA512 e2874e10e12070e8e1b9c01f41ce24002a3859c4aca8bf46083ea08e68f44ed6725bdcdf8e592b1e50d69975d506836c62a8e10fc6da00f0844c149dd6676996
+EBUILD nlohmann_json-3.5.0.ebuild 630 BLAKE2B 5907fb893b6968dfa971774c642d6539be3c04c6282ae9f5151668a50236ab096e368f48d3074326c63d3f4ab32adcc0d0f9b5df61f086e1036c3e3a87451b90 SHA512 817265e913bbbe88c63bec149c211edc987a45eb5ac25d76702bd6698ca319537c651d3291b778c86f6a46d50dfd3592772bb2557a5d491a772b8e7285f5b751
+MISC metadata.xml 337 BLAKE2B a929f6f116c9b0bdf3415325cc710b4b2afa1bb2b6a74c8df9531ad0358d8141054cee8be2be7b380574a8c59359f1c9e9bd8b7fcb607b8da251b787d75dcf43 SHA512 d6ae8564e57c1062487634fb7d4e2c0fa4c79a38d89c06c3514d3459cfd08500634a5fc8add1e126f3181b711dae74931c906b67f6aac51d6400cd2800f293df
diff --git a/dev-cpp/nlohmann_json/metadata.xml b/dev-cpp/nlohmann_json/metadata.xml
new file mode 100644
index 000000000000..eb8bff7e3814
--- /dev/null
+++ b/dev-cpp/nlohmann_json/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ <name>Gentoo Video project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nlohmann/json</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild
new file mode 100644
index 000000000000..56411b042378
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_compile() {
+ meson_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ meson_src_install
+ use doc && dodoc -r doc/html
+}