summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-cpp/nlohmann_json
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest2
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild33
2 files changed, 16 insertions, 19 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 16e266bbff34..da2ab8122e98 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -7,5 +7,5 @@ DIST nlohmann_json-3.9.1.tar.gz 6882818 BLAKE2B 97276dc2345ac2070ac2d30d0a2e1953
EBUILD nlohmann_json-3.6.1-r1.ebuild 798 BLAKE2B 65d37e21588513c043122349c2e89450565b16c534d58849c8af36a9f14695296c624664db03585f0dfa5e8ec935dabf765290155a38714a28fc749bf66c02ea SHA512 b693e518ec9a21edbba894628d31db72463f0c54a4ae7aee190c680abec3b5197937367f44d6aaf5673a31e7a86114760ae3016a9acbec4463038dd8abbbf4c7
EBUILD nlohmann_json-3.7.0.ebuild 802 BLAKE2B a224e06c3ef1199734674a2f693c448a1c621a2426887912510d5a09fdca0e9a108adf982bf074306098b428e5eef0d4b2ac02697038bdf41ab4c0dc38e39e82 SHA512 8499faa38a4de2f8733bfaeb2484cf7a125819db48836df2a72cefc7c107d88db5574f8096243d91f4c3e4b97a5f56e53c4fe98bb471636ff3f50d6bb107215b
EBUILD nlohmann_json-3.7.3.ebuild 858 BLAKE2B 852622cec3d775387e1a63bd1c7fdec647d5aebb7d672dd90f780e04cfd3c254f76a56363d4b955277b80aa48dd99e8e044680735fa5a3ff05b575f64e2cdc8f SHA512 4a9435489e2fb3840ef663a915004056d3faa0ea2b6bc24d9d77d74e5c7ccdf2700a1a568938a27e7bc071bb5a9068165369e8f51d20b6217151c578c146ea55
-EBUILD nlohmann_json-3.9.1.ebuild 1372 BLAKE2B fc3932b18b1a6bc51d9a31f894444e2b4605b0fa35bc326ceb5208ac80f440a9f91b640fb504e3389b464fe395a63f5000efb24d09d22f66991e0365385a3b5c SHA512 eb4f31474af6344b6c0548b1501d01af6876a0eb9b60fb21c806179ee5e295b67f10d3fcd8611d1771ebeff97ac1e0d225e122a9c335993202621c7093467e93
+EBUILD nlohmann_json-3.9.1.ebuild 1397 BLAKE2B e38e495ca4ef55e7243aa2fdb0c97ebc83bdb742b5a1e54b6bc68c2375d7ab65b56c17cfcbdf2849ebc12b01326e6ddb94658c2ee6f478f4b89b177f7bdc2414 SHA512 3c422cddda9ad2b1c7115c18912838a47f61f475761b7e2b41c2be46e4c2c921d95401464e2bdb66a0747ced0617edd8dbca4becaed320d9a2f0601180dc73c5
MISC metadata.xml 337 BLAKE2B a929f6f116c9b0bdf3415325cc710b4b2afa1bb2b6a74c8df9531ad0358d8141054cee8be2be7b380574a8c59359f1c9e9bd8b7fcb607b8da251b787d75dcf43 SHA512 d6ae8564e57c1062487634fb7d4e2c0fa4c79a38d89c06c3514d3459cfd08500634a5fc8add1e126f3181b711dae74931c906b67f6aac51d6400cd2800f293df
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index cbad769efb0c..9e63f828a377 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,8 +7,9 @@ inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
+SRC_URI="
+ https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
S="${WORKDIR}/json-${PV}"
LICENSE="MIT"
@@ -20,29 +21,30 @@ IUSE="doc test"
# Tests only just added, large test suite, majority pass
RESTRICT="test"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog.md README.md )
src_configure() {
+ # Tests are built by default so we can't group the test logic below
local mycmakeargs=(
-DJSON_MultipleHeaders=ON
+ -DJSON_BuildTests=$(usex test)
)
- if use test ; then
- # Define test data directory here to avoid unused var QA warning
- # #747826
- mycmakeargs+=(
- -DJSON_BuildTests=ON
- -DJSON_TestDataDirectory="${S}/json_test_data"
- )
- fi
+ # Define test data directory here to avoid unused var QA warning, bug #747826
+ use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
+
cmake_src_configure
}
src_compile() {
cmake_src_compile
- use doc && emake -C doc
+
+ if use doc; then
+ emake -C doc
+ HTML_DOCS=( doc/html/. )
+ fi
}
src_test() {
@@ -56,8 +58,3 @@ src_test() {
cmake_src_test
}
-
-src_install() {
- cmake_src_install
- use doc && dodoc -r doc/html
-}