summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-cpp/nlohmann_json
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest4
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild8
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild8
3 files changed, 10 insertions, 10 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 0c0b87bd6cbf..8bb34ca425fc 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,5 +1,5 @@
DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
DIST nlohmann_json-3.7.0.tar.gz 118868542 BLAKE2B 25191628b737ea5614de85d0fcb4425fcb2d37e6890626e6ba22949430a1c5f827ff17d1cd8245c8e98d0deda617d8268c55caff3017a6b4a2f730e524599311 SHA512 35510a0ee59d847ff9fcd4f4026ef936abb89675884fdd2db808f8349a55073206f764cd4f797deb1b6493ea0e04889505f49483e5b88798011dd5db87e7c87d
-EBUILD nlohmann_json-3.6.1-r1.ebuild 822 BLAKE2B 942b7b682266918a2f1b26485efb4c67a3a787bff15317b818f9c4ecfbe5170a1c7e752a1055e268acf063cef0e5428ec67ce7795e5e716365d5fc4b2bf353bc SHA512 acc741720993c181f7a57159ee8c590025a8163eac291ffb81e5f10458510e2070ec5936ab7b63b6363d8dba7a1b6c1f8500e947ca66e5e11874571d43bfb54b
-EBUILD nlohmann_json-3.7.0.ebuild 826 BLAKE2B ad11525844e3218cc5f8fdfd53ae1555485a69c0a09373116cfb76c2c0a128e21eac91cb4b6df7132247ec234705d38eafe4b510120c4c1b09a3a016b5c8d826 SHA512 3da1d5e5080d2e9747ef8054a0003fb651631b6af2d7a4374c2202407833137e15434751f5e513a8dd9b67bb16b49203c813915496aaf47f65f502d44e273097
+EBUILD nlohmann_json-3.6.1-r1.ebuild 798 BLAKE2B 65d37e21588513c043122349c2e89450565b16c534d58849c8af36a9f14695296c624664db03585f0dfa5e8ec935dabf765290155a38714a28fc749bf66c02ea SHA512 b693e518ec9a21edbba894628d31db72463f0c54a4ae7aee190c680abec3b5197937367f44d6aaf5673a31e7a86114760ae3016a9acbec4463038dd8abbbf4c7
+EBUILD nlohmann_json-3.7.0.ebuild 802 BLAKE2B a224e06c3ef1199734674a2f693c448a1c621a2426887912510d5a09fdca0e9a108adf982bf074306098b428e5eef0d4b2ac02697038bdf41ab4c0dc38e39e82 SHA512 8499faa38a4de2f8733bfaeb2484cf7a125819db48836df2a72cefc7c107d88db5574f8096243d91f4c3e4b97a5f56e53c4fe98bb471636ff3f50d6bb107215b
MISC metadata.xml 337 BLAKE2B a929f6f116c9b0bdf3415325cc710b4b2afa1bb2b6a74c8df9531ad0358d8141054cee8be2be7b380574a8c59359f1c9e9bd8b7fcb607b8da251b787d75dcf43 SHA512 d6ae8564e57c1062487634fb7d4e2c0fa4c79a38d89c06c3514d3459cfd08500634a5fc8add1e126f3181b711dae74931c906b67f6aac51d6400cd2800f293df
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
index d7e7355ddcf4..3f251a81fd24 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
index ed480ec910fb..6c95f15b7348 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}