summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
deleted file mode 100644
index 6c95f15b7348..000000000000
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="JSON for Modern C++"
-HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="doc? ( app-doc/doxygen )"
-
-DOCS=( ChangeLog.md README.md )
-
-S=${WORKDIR}/json-${PV}
-
-src_configure() {
- local mycmakeargs=(
- -DJSON_BuildTests=$(usex test)
- -DJSON_MultipleHeaders=ON
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && emake -C doc
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- cmake_src_install
- use doc && dodoc -r doc/html
-}