summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild
deleted file mode 100644
index 39a2c4c723af..000000000000
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.10.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
-TEST_VERSION="3.0.0"
-DESCRIPTION="JSON for Modern C++"
-HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="
- https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
-S="${WORKDIR}/json-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="doc test"
-#RESTRICT="!test? ( test )"
-# Need to report failing tests upstream
-# Tests only just added, large test suite, majority pass
-RESTRICT="test"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-
-DOCS=( ChangeLog.md README.md )
-
-src_configure() {
- # Tests are built by default so we can't group the test logic below
- local mycmakeargs=(
- -DJSON_MultipleHeaders=ON
- -DJSON_BuildTests=$(usex test)
- )
-
- # Define test data directory here to avoid unused var QA warning, bug #747826
- use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc; then
- emake -C doc
- HTML_DOCS=( doc/html/. )
- fi
-}
-
-src_test() {
- cd "${BUILD_DIR}/test" || die
-
- # Skip certain tests needing git per upstream
- # https://github.com/nlohmann/json/issues/2189
- local myctestargs=(
- "-LE git_required"
- )
-
- cmake_src_test
-}