summaryrefslogtreecommitdiff
path: root/dev-cpp/muParserX
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-cpp/muParserX
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-cpp/muParserX')
-rw-r--r--dev-cpp/muParserX/Manifest3
-rw-r--r--dev-cpp/muParserX/metadata.xml19
-rw-r--r--dev-cpp/muParserX/muParserX-4.0.11.ebuild16
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/muParserX/Manifest b/dev-cpp/muParserX/Manifest
new file mode 100644
index 000000000000..fde746401cd3
--- /dev/null
+++ b/dev-cpp/muParserX/Manifest
@@ -0,0 +1,3 @@
+DIST muParserX-4.0.11.tar.gz 215824 BLAKE2B f077fee44d4b67b02a0c559ce492b27107b0f5294eca7266e968c852e1e2503a4f5fc4d32b07e5c6ebca8ab95d7f30cdacd257439f70a7943c5ad22d111139c9 SHA512 67846a91b57e41731a656cfee68effdd9166e738108764be5d3080854d8a01bedbeacaaade7bee11c6b5f83019abddeca3b2c9acdfbb48629da6d9b92c79c7af
+EBUILD muParserX-4.0.11.ebuild 441 BLAKE2B 3cc52724f96f990d000642cf4e4c17616c13e032be231ca7b4fcb2354493dd6a6cd60249e8ba414bdfa7205f7ae6b3afa71d897de703fab5da4836c2b5d556f3 SHA512 702c9c47600622ce1ccd5217837451dbd105cf2b91b54928aa70dab8aab83ff7da7fa0060894a25593a0a18a4e0e53b6e96b3d3bb47980abb25c9b7e66cbe6c5
+MISC metadata.xml 1154 BLAKE2B 60fd7234e520e54cbc46fbc0fda2bbcb4ed71f2f8f2067619dad79a20f7917088fdbd4a54d65bde0e13cd8d486ffde65ad42a79dd5ba27a0b569cc5ed9aaaecd SHA512 4cf74c1bde49cc2ef074dd0728712b3a2f78633033bac2323f46bc06fc72d96fac5145bb5e9af27ed422b991a934656f199c5477692b32776b0941ccb40474e1
diff --git a/dev-cpp/muParserX/metadata.xml b/dev-cpp/muParserX/metadata.xml
new file mode 100644
index 000000000000..f9242a1fe47a
--- /dev/null
+++ b/dev-cpp/muParserX/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The evaluation of a mathematical expression is a standard task required in many applications. It can be solved by either using a standard math expression parser such as muparser or by embedding a scripting language such as Lua. There are however some limitations: Although muparser is pretty fast it will only work with scalar values and although Lua is very flexible it does neither support binary operators for arrays nor complex numbers. So if you need a math expression parser with support for arrays, matrices and strings muparserx may be able to help you.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">beltoforion/muparserx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/muParserX/muParserX-4.0.11.ebuild b/dev-cpp/muParserX/muParserX-4.0.11.ebuild
new file mode 100644
index 000000000000..373e92ac6637
--- /dev/null
+++ b/dev-cpp/muParserX/muParserX-4.0.11.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Parsing Expressions with Strings, Complex Numbers, Vectors, Matrices and more"
+HOMEPAGE="https://beltoforion.de/en/muparser/"
+SRC_URI="https://github.com/beltoforion/muparserx/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}"/muparserx-${PV}