summaryrefslogtreecommitdiff
path: root/dev-cpp/lucene++
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/lucene++
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/lucene++')
-rw-r--r--dev-cpp/lucene++/Manifest4
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch37
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7.ebuild36
-rw-r--r--dev-cpp/lucene++/metadata.xml11
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/Manifest b/dev-cpp/lucene++/Manifest
new file mode 100644
index 000000000000..206373086cce
--- /dev/null
+++ b/dev-cpp/lucene++/Manifest
@@ -0,0 +1,4 @@
+AUX lucene++-3.0.7-boost-1.58.patch 1149 BLAKE2B 0021a7a27caabb92232adb42c7b1e8d4832902954018be4bf89e2765562e1e26cc29a67dc75be82f9d2ca7dfddd1e137fc742850d6707527da04574f2b1bbac9 SHA512 7fd0089895ab77da158a49510241fdc894bd3d30f7a6691ddc230f4d52631ec9222a04e13ef0a118f7838b4320fd313502f635c8f0827ba5bb4c6169fdd404b9
+DIST lucene++-3.0.7.tar.gz 2013570 BLAKE2B 26abb1a2fa2a24d7240505f11639c078744313541b4993ed84e4d0129fda74346e841f0c4c7552e58a15dd492af9ffd33ea66866c8e6810cd41e5d675833ce79 SHA512 92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220
+EBUILD lucene++-3.0.7.ebuild 811 BLAKE2B 1d28c365548431db7973b5f743ca3375f7daed1c31f92f7f5dc25e15ef0bf1d3234234e8bb1b4c9f19b15209fe08eee2c869565c32912d3783c46b92f48a86f2 SHA512 c40875d5e138ad869cba0c72307029ff4c9945dfac6e091ab3c83dc553412761ce8c7d7f65cabceb57abd4cf10679da46905f54ee3cafe6f22b7415e3295aab2
+MISC metadata.xml 339 BLAKE2B e503e6597ab8a20f9cb8613a4a4b7be729dd84d664b03fefa4cebe16da9adbea68de1adabf0055934815a70abfbdcd8f7603c7b7ff4a75bf8fac7973790a7412 SHA512 8864d26ad6eb0c9e565932a3f9a0e28e0e86c51998136e9ff56c2ef3fe0e7eb78bcc5d3b7a5e3acdbd0a89f3cf335e2af837a1ed3f0e492db42492e5a85eac26
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch b/dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch
new file mode 100644
index 000000000000..9ff33fd03005
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.7-boost-1.58.patch
@@ -0,0 +1,37 @@
+commit 1987082cf9278a639d772b4f35a8ae2d34944177
+Author: Václav Slavík <vaclav@slavik.io>
+Date: Mon May 4 18:04:46 2015 +0200
+
+ Fix compilation with Boost 1.58
+
+ 1.58 introduces strict type checking in boost::get() and while that's
+ good in theory, the VariantUtils code makes it impractical to use.
+ Instead, use relaxed_get() to get the old behavior. relaxed_get() didn't
+ exist in older versions of Boost, so the code must check BOOST_VERSION.
+
+ Fixes #93.
+
+diff --git a/include/VariantUtils.h b/include/VariantUtils.h
+index 1e6c243..5a72e59 100644
+--- a/include/VariantUtils.h
++++ b/include/VariantUtils.h
+@@ -8,6 +8,7 @@
+ #define VARIANTUTILS_H
+
+ #include <boost/any.hpp>
++#include <boost/version.hpp>
+ #include "Lucene.h"
+ #include "MiscUtils.h"
+
+@@ -22,7 +23,11 @@ public:
+
+ template <typename TYPE, typename VAR>
+ static TYPE get(VAR var) {
++#if BOOST_VERSION < 105800
+ return var.type() == typeid(TYPE) ? boost::get<TYPE>(var) : TYPE();
++#else
++ return var.type() == typeid(TYPE) ? boost::relaxed_get<TYPE>(var) : TYPE();
++#endif
+ }
+
+ template <typename TYPE, typename VAR>
diff --git a/dev-cpp/lucene++/lucene++-3.0.7.ebuild b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
new file mode 100644
index 000000000000..7041d7913dce
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/lucene++/metadata.xml b/dev-cpp/lucene++/metadata.xml
new file mode 100644
index 000000000000..3eaca1156f33
--- /dev/null
+++ b/dev-cpp/lucene++/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">luceneplusplus/luceneplusplus</remote-id>
+ </upstream>
+</pkgmetadata>