summaryrefslogtreecommitdiff
path: root/dev-cpp/libcmis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-cpp/libcmis/files
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-cpp/libcmis/files')
-rw-r--r--dev-cpp/libcmis/files/libcmis-0.5.2-boost-1.68.patch25
-rw-r--r--dev-cpp/libcmis/files/libcmis-0.5.2-oauth2-encode.patch69
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-cpp/libcmis/files/libcmis-0.5.2-boost-1.68.patch b/dev-cpp/libcmis/files/libcmis-0.5.2-boost-1.68.patch
new file mode 100644
index 000000000000..767464242f78
--- /dev/null
+++ b/dev-cpp/libcmis/files/libcmis-0.5.2-boost-1.68.patch
@@ -0,0 +1,25 @@
+From 3ef3569c4ae1c5319aff0664d52cbd8a8d42c909 Mon Sep 17 00:00:00 2001
+From: rezso <rezso@rezso.net>
+Date: Tue, 4 Sep 2018 01:18:10 +0200
+Subject: tdf#119344 fix libcmis build with boost 1.68
+
+Change-Id: I80d6ea8ecd001dc02b941c1eb8974c9244316045
+Reviewed-on: https://gerrit.libreoffice.org/59958
+Tested-by: Jenkins
+Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
+
+--- a/src/libcmis/xml-utils.cxx
++++ b/src/libcmis/xml-utils.cxx
+@@ -31,7 +31,12 @@
+ #include <sstream>
+ #include <stdlib.h>
+
++#include <boost/version.hpp>
++#if (BOOST_VERSION >= 106800)
++#include <boost/uuid/detail/sha1.hpp>
++#else
+ #include <boost/uuid/sha1.hpp>
++#endif
+ #include <curl/curl.h>
+
+ #include "xml-utils.hxx"
diff --git a/dev-cpp/libcmis/files/libcmis-0.5.2-oauth2-encode.patch b/dev-cpp/libcmis/files/libcmis-0.5.2-oauth2-encode.patch
new file mode 100644
index 000000000000..c6a99074c502
--- /dev/null
+++ b/dev-cpp/libcmis/files/libcmis-0.5.2-oauth2-encode.patch
@@ -0,0 +1,69 @@
+From 33f7485dedea90e0f80c6348fa8ac5f27c5052e0 Mon Sep 17 00:00:00 2001
+From: Stephan Bergmann <sbergman@redhat.com>
+Date: Tue, 4 Sep 2018 16:45:00 +0200
+Subject: Properly encode OAuth2 credentials
+
+Change-Id: Ic3edeae035262309e91fb01e3aca5c2f905bc3e5
+Reviewed-on: https://gerrit.libreoffice.org/59986
+Tested-by: Jenkins
+Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
+
+--- a/src/libcmis/oauth2-providers.cxx
++++ b/src/libcmis/oauth2-providers.cxx
+@@ -26,6 +26,8 @@
+ * instead of those above.
+ */
+
++#include <cassert>
++
+ #include <libxml/HTMLparser.h>
+ #include <libxml/xmlreader.h>
+
+@@ -45,6 +47,29 @@
+ #define HTML_PARSE_RECOVER 0
+ #endif
+
++namespace {
++
++// See <https://url.spec.whatwg.org/#concept-urlencoded-byte-serializer>:
++void addXWwwFormUrlencoded(std::string * buffer, std::string const & data) {
++ assert(buffer);
++ for (string::const_iterator i = data.begin(); i != data.end(); ++i) {
++ unsigned char c = static_cast<unsigned char>(*i);
++ if (c == ' ' || c == '*' || c == '-' || c == '.' || (c >= '0' && c <= '9')
++ || (c >= 'A' && c <= 'Z') || c == '_' || (c >= 'a' && c <= 'z'))
++ {
++ *buffer += static_cast<char>(c);
++ } else {
++ static const char hex[16] = {
++ '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C', 'D', 'E', 'F'};
++ *buffer += '%';
++ *buffer += hex[c >> 4];
++ *buffer += hex[c & 0xF];
++ }
++ }
++}
++
++}
++
+ string OAuth2Providers::OAuth2Gdrive( HttpSession* session, const string& authUrl,
+ const string& username, const string& password )
+ {
+@@ -97,7 +120,7 @@
+ return string( );
+
+ loginEmailPost += "Email=";
+- loginEmailPost += string( username );
++ addXWwwFormUrlencoded(&loginEmailPost, username);
+
+ istringstream loginEmailIs( loginEmailPost );
+ string loginEmailRes;
+@@ -119,7 +142,7 @@
+ return string( );
+
+ loginPasswdPost += "Passwd=";
+- loginPasswdPost += string( password );
++ addXWwwFormUrlencoded(&loginPasswdPost, password);
+
+ istringstream loginPasswdIs( loginPasswdPost );
+ string loginPasswdRes;