summaryrefslogtreecommitdiff
path: root/dev-cpp/highway
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-cpp/highway
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-cpp/highway')
-rw-r--r--dev-cpp/highway/Manifest5
-rw-r--r--dev-cpp/highway/files/highway-0.16.0-fix-AVX512-detection-on-IceLakeClient.patch17
-rw-r--r--dev-cpp/highway/highway-0.16.0-r1.ebuild (renamed from dev-cpp/highway/highway-0.16.0.ebuild)6
-rw-r--r--dev-cpp/highway/highway-9999.ebuild2
4 files changed, 26 insertions, 4 deletions
diff --git a/dev-cpp/highway/Manifest b/dev-cpp/highway/Manifest
index 40ca0ece8be8..e88160836824 100644
--- a/dev-cpp/highway/Manifest
+++ b/dev-cpp/highway/Manifest
@@ -1,4 +1,5 @@
+AUX highway-0.16.0-fix-AVX512-detection-on-IceLakeClient.patch 569 BLAKE2B 89915c3fc3e934415026bbc8e19bd8d50b6e3e438f1942b0345832ae6067f7ffaf714d3b99efd3876c6774966cb0cdee05f1dc87788b37c072199d5c714cb937 SHA512 99333059c069f09c59281a7f464805eb41cc6da627dd11ac7dcc565fd688532f162776897ebf506c50e58f17dc7a9486214cc1ec683cb8b2c7efa8b767574410
DIST highway-0.16.0.tar.gz 1639388 BLAKE2B 660b0079b25a12a2e982b4ba16147b923d167989a7dc1c0cb65ebe5219577f2f02c8774a554fd3fe9e1c10ef7b1cf5db747500bd8acf454e26952722f7b5ac9e SHA512 c08e66f43d9d0b307737b016cfa6c3d3a1df9bd528de435d193388104f34c264866c5ff0da633fc0a6f8c50f21df1ac653e9dd3f6fbfaf227d636411ac14cd47
-EBUILD highway-0.16.0.ebuild 827 BLAKE2B 5086672711f1f60342b6f77ddcd850d845c499d34c13f1f181721bf677c3cc21cdbc6967e6203e084c1cf697b4dd053580efbfb6ca5362369ba0b81577a2dbc6 SHA512 c4f183d1abe116d4994e90044ae957d631e57d2efe95644c650a899de70be366ce683e1332d87c2123e46a6c13a18c44de95fc6ce638ac0272309355aeed5f1e
-EBUILD highway-9999.ebuild 827 BLAKE2B 5086672711f1f60342b6f77ddcd850d845c499d34c13f1f181721bf677c3cc21cdbc6967e6203e084c1cf697b4dd053580efbfb6ca5362369ba0b81577a2dbc6 SHA512 c4f183d1abe116d4994e90044ae957d631e57d2efe95644c650a899de70be366ce683e1332d87c2123e46a6c13a18c44de95fc6ce638ac0272309355aeed5f1e
+EBUILD highway-0.16.0-r1.ebuild 942 BLAKE2B 9fb7283832fd7064ecfd2737d2211788004763fb9ce97a70af64ca9867d50c42d2cd0f34e32608179cc3950aa59cd1a2e5f5d22a0eb5404a1b03355ceb5f41d0 SHA512 320e54fbba2da543642ea3d01c355bb2ece387aa5f96cfaffed33ef480285ab57fe89f1a96308d14dd4b73d1d35391f77e8700002b6733c6ac72f5589a5eb892
+EBUILD highway-9999.ebuild 834 BLAKE2B bb10c9e76cac9a5149824c3f7def1928cbb19db5f7612aa22b8d5aace561483cb7d391e95a21be12edb73c87b3ce5e2a0ae4bb652ea8cfc2f9976b9afecdad8c SHA512 68cf57994bbed31f0ecc10e876ab78edef1af6c1af5be91e2d6ee7758b962799104873795d7c6ce443a2b4cc68c2324823b4e0d8233ca95eeeeb61b042bb5487
MISC metadata.xml 616 BLAKE2B d7aed88bf99a4e1370c0007e2eeb0d9e8a64c888cf1ef428f5096e40d75497a7255ceeeb73b68d7bb3afe44f65073811759dbb61f2270d4a8fdbc0721c7b27dd SHA512 855f548c51686530649f9eb1d5a8f4441f8dca8377622acc3cd32562b58556000dec77ba7c162e8f00443e85b75fde81d2cc900c1741ed76f815e3521d2602e4
diff --git a/dev-cpp/highway/files/highway-0.16.0-fix-AVX512-detection-on-IceLakeClient.patch b/dev-cpp/highway/files/highway-0.16.0-fix-AVX512-detection-on-IceLakeClient.patch
new file mode 100644
index 000000000000..de157925c6ef
--- /dev/null
+++ b/dev-cpp/highway/files/highway-0.16.0-fix-AVX512-detection-on-IceLakeClient.patch
@@ -0,0 +1,17 @@
+https://github.com/google/highway/commit/daf441c78191b3433410498d27a5bfdfdf93a142
+
+diff --git a/hwy/targets.cc b/hwy/targets.cc
+index 2a0ab4ef..7e7e2d79 100644
+--- a/hwy/targets.cc
++++ b/hwy/targets.cc
+@@ -328,8 +328,8 @@ uint32_t SupportedTargets() {
+ if (!IsBitSet(xcr0, 2)) {
+ bits &= ~uint32_t(HWY_AVX2 | HWY_AVX3 | HWY_AVX3_DL);
+ }
+- // ZMM + opmask
+- if ((xcr0 & 0x70) != 0x70) {
++ // opmask, ZMM lo/hi
++ if (!IsBitSet(xcr0, 5) || !IsBitSet(xcr0, 6) || !IsBitSet(xcr0, 7)) {
+ bits &= ~uint32_t(HWY_AVX3 | HWY_AVX3_DL);
+ }
+ }
diff --git a/dev-cpp/highway/highway-0.16.0.ebuild b/dev-cpp/highway/highway-0.16.0-r1.ebuild
index 4371d5e0bc03..52fb0b16d961 100644
--- a/dev-cpp/highway/highway-0.16.0.ebuild
+++ b/dev-cpp/highway/highway-0.16.0-r1.ebuild
@@ -14,7 +14,7 @@ if [[ "${PV}" == *9999* ]]; then
EGIT_REPO_URI="https://github.com/google/highway.git"
else
SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
LICENSE="Apache-2.0"
@@ -25,6 +25,10 @@ DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-AVX512-detection-on-IceLakeClient.patch
+)
+
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
diff --git a/dev-cpp/highway/highway-9999.ebuild b/dev-cpp/highway/highway-9999.ebuild
index 4371d5e0bc03..2c36b3475aba 100644
--- a/dev-cpp/highway/highway-9999.ebuild
+++ b/dev-cpp/highway/highway-9999.ebuild
@@ -14,7 +14,7 @@ if [[ "${PV}" == *9999* ]]; then
EGIT_REPO_URI="https://github.com/google/highway.git"
else
SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="Apache-2.0"