summaryrefslogtreecommitdiff
path: root/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild')
-rw-r--r--dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild b/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
new file mode 100644
index 000000000000..15eb354118a3
--- /dev/null
+++ b/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only single-file std::filesystem compatible helper library"
+HOMEPAGE="https://github.com/gulrak/filesystem"
+SRC_URI="https://github.com/gulrak/filesystem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${P#*-}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGHC_FILESYSTEM_BUILD_EXAMPLES=OFF
+ -DGHC_FILESYSTEM_BUILD_TESTING=$(usex test)
+ -DGHC_FILESYSTEM_WITH_INSTALL=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ docinto examples
+ use examples && dodoc examples/*.cpp
+}