summaryrefslogtreecommitdiff
path: root/dev-cpp/gtest/gtest-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
commit2929788def9a92c1eb237eed93fbdb0c02838bbf (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /dev-cpp/gtest/gtest-1.10.0.ebuild
parentab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (diff)
Revert "gentoo resync : 13.10.2019"
This reverts commit ab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030.
Diffstat (limited to 'dev-cpp/gtest/gtest-1.10.0.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-1.10.0.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/dev-cpp/gtest/gtest-1.10.0.ebuild b/dev-cpp/gtest/gtest-1.10.0.ebuild
deleted file mode 100644
index 2a75dd1da0e7..000000000000
--- a/dev-cpp/gtest/gtest-1.10.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit cmake-multilib python-any-r1
-
-MY_PV=1.10.x
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/google/googletest"
-else
- if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- URI_PV=v${MY_PV:-${PV}}
- else
- URI_PV=${MY_PV:=${GOOGLETEST_COMMIT}}
- fi
- SRC_URI="https://github.com/google/googletest/archive/${URI_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}"/googletest-${MY_PV}
-fi
-
-DESCRIPTION="Google C++ Testing Framework"
-HOMEPAGE="https://github.com/google/googletest"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc examples test"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-RDEPEND="!dev-cpp/gmock"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.0_pre20190607-increase-clone-stack-size.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e '/set(cxx_base_flags /s:-Werror::' \
- googletest/cmake/internal_utils.cmake || die "sed failed!"
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_GMOCK=ON
- -DINSTALL_GTEST=ON
-
- # tests
- -Dgmock_build_tests=$(usex test)
- -Dgtest_build_tests=$(usex test)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use doc; then
- docinto googletest
- dodoc -r googletest/docs/.
- docinto googlemock
- dodoc -r googlemock/docs/.
- fi
-
- if use examples; then
- docinto examples
- dodoc googletest/samples/*.{cc,h}
- fi
-}