summaryrefslogtreecommitdiff
path: root/dev-cpp/gsl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
commita833e3f4a431b8eea751b7420e127787f9c92117 (patch)
treeb941d23e9e3d5f070b01feb15ef927839af7456a /dev-cpp/gsl
parent4cd2370bed609c118b6edfde5d3f116e5c35b897 (diff)
gentoo resync : 04.12.2017
Diffstat (limited to 'dev-cpp/gsl')
-rw-r--r--dev-cpp/gsl/Manifest3
-rw-r--r--dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch31
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-cpp/gsl/Manifest b/dev-cpp/gsl/Manifest
index cf0aa7146490..08b83117c886 100644
--- a/dev-cpp/gsl/Manifest
+++ b/dev-cpp/gsl/Manifest
@@ -1,3 +1,4 @@
-DIST gsl-0_pre20171105.tar.gz 55870 SHA256 5adc4b4ba53102099f63b898da161469a854d4fd47e90195421fbe8bd8b50352 SHA512 0db9cae9af710c45f66d1e2b73e2002f921876d400165d13dbe9ede7aa9335249458a9f97d4eda4cff0b3a5ceebb6ef84b631310921011fedee8776fcec89e6a WHIRLPOOL 98e26057646f6be4cc6632901b2b45c5e46218e9048cd64561f7f118ee0e8feadeca3ca66a0b73a36a431b666fe7946c6f864dbcf97296bae3945b2350dcf2e5
+AUX gsl-0_pre20171105-use_system_catch-636828.patch 921 BLAKE2B e2dcbb1b8ccfd7047565f70c0e487b1da699d832a8dc66c7f7824fbfa3d9f12bcecd82dca4d23af02efb467577cd0e3c23bab0eb99778e755504b3569e863668 SHA512 4581e4c3a6408458936b7b49a269bb62d46c8d313f7bf10ba7c7eae642d62baaa2e8ddca5e46e54591fe91e65389e0d4b0fc272c90bdf94c6b08acb3d3160a5f
+DIST gsl-0_pre20171105.tar.gz 55870 BLAKE2B cc26a8a304a65cd6a487d22369b5b23169e07144a7629388fffdbf263619c0849f00efcc1a072408e3e89dd933e3309c15049d0fec30de07267b5b693c5c9657 SHA512 0db9cae9af710c45f66d1e2b73e2002f921876d400165d13dbe9ede7aa9335249458a9f97d4eda4cff0b3a5ceebb6ef84b631310921011fedee8776fcec89e6a
EBUILD gsl-0_pre20171105.ebuild 601 BLAKE2B 6d56f6463b3a675fe752d541ef1ed7fd92ab24fb08bb870e00755fbb5d9f37ee1814442d221aa1180e257283917f8280c5486ce452ff73ad82da1962ff5f43cd SHA512 1f01a505b9716fafe174435051fe5a41168bf5aa7d9c2b3c46b3dac8848f3e9d31b6c7dedbc67323e9fa813f45d365e06c790eb57d0680cdcd8307e478c19714
MISC metadata.xml 546 BLAKE2B 8ed1288cb4f89f8e15554171875541dd0d100b2d6608d5093e5be319a08e5a03334865548bd8c42337723961af42a75d2ad160acf58f259b4107c790e032ab12 SHA512 e5aa4be86c8c44e14384ec27e0a7a14f246ee60a1b789d97bd67ef5d00553f09449aa6ec0eb51fd4a6b17d25e8ccffe6b9a7921056bc406acf758ae2de6bd958
diff --git a/dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch b/dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch
new file mode 100644
index 000000000000..e72eae02311e
--- /dev/null
+++ b/dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch
@@ -0,0 +1,31 @@
+# Disable upstreams catch download, we always want to use the system installed
+# version. Gentoo bug 636828.
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 86ce5a4..9b7d4f7 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -10,21 +10,8 @@ list(APPEND CATCH_CMAKE_ARGS
+ "-DNO_SELFTEST=true"
+ )
+
+-if(GIT_FOUND)
+- # add catch
+- ExternalProject_Add(
+- catch
+- PREFIX ${CMAKE_BINARY_DIR}/catch
+- GIT_REPOSITORY https://github.com/catchorg/Catch2.git
+- GIT_TAG v2.0.1
+- CMAKE_ARGS ${CATCH_CMAKE_ARGS}
+- LOG_DOWNLOAD 1
+- UPDATE_DISCONNECTED 1
+- )
+-else()
+- # assume catch is installed in a system directory
+- add_custom_target(catch)
+-endif()
++# assume catch is installed in a system directory
++add_custom_target(catch)
+
+ # this interface adds compile options to how the tests are run
+ # please try to keep entries ordered =)