summaryrefslogtreecommitdiff
path: root/dev-cpp/glog/glog-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-cpp/glog/glog-0.4.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-cpp/glog/glog-0.4.0.ebuild')
-rw-r--r--dev-cpp/glog/glog-0.4.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-cpp/glog/glog-0.4.0.ebuild b/dev-cpp/glog/glog-0.4.0.ebuild
index c5097b33e782..c81238fb365c 100644
--- a/dev-cpp/glog/glog-0.4.0.ebuild
+++ b/dev-cpp/glog/glog-0.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2011-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,11 +11,12 @@ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="gflags static-libs test"
RESTRICT="test"
-RDEPENDS="sys-libs/libunwind[${MULTILIB_USEDEP}]"
+RDEPENDS="sys-libs/libunwind[${MULTILIB_USEDEP}]
+ gflags? ( dev-cpp/gflags[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
@@ -32,7 +33,8 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ ac_cv_lib_gflags_main="$(usex gflags)"
}
multilib_src_install_all() {