summaryrefslogtreecommitdiff
path: root/dev-cpp/gflags/gflags-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 04:28:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 04:28:45 +0100
commit7e110ec617b903791c3d309845e11a8b27f441cc (patch)
treed9e8b4826e21ef9fa1fc2255d459f563d5581283 /dev-cpp/gflags/gflags-2.2.2.ebuild
parentf2a91413828611d85d0496e98e1656e9b0e4528b (diff)
gentoo auto-resync : 11:07:2023 - 04:28:45
Diffstat (limited to 'dev-cpp/gflags/gflags-2.2.2.ebuild')
-rw-r--r--dev-cpp/gflags/gflags-2.2.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-cpp/gflags/gflags-2.2.2.ebuild b/dev-cpp/gflags/gflags-2.2.2.ebuild
deleted file mode 100644
index da0ea88c47b5..000000000000
--- a/dev-cpp/gflags/gflags-2.2.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gflags/gflags"
-else
- SRC_URI="https://github.com/gflags/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="Google's C++ argument parsing library"
-HOMEPAGE="https://gflags.github.io/gflags/"
-
-LICENSE="BSD"
-SLOT="0/2.2"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-# AUTHORS.txt only links the google group
-DOCS=( ChangeLog.txt README.md )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_STATIC_LIBS=$(usex static-libs)
- -DBUILD_TESTING=$(usex test)
- # avoid installing .cmake/packages, e.g.:
- # >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
- -DREGISTER_INSTALL_PREFIX=OFF
- )
- cmake_src_configure
-}