summaryrefslogtreecommitdiff
path: root/dev-cpp/gccxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/gccxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/gccxml')
-rw-r--r--dev-cpp/gccxml/Manifest3
-rw-r--r--dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild33
-rw-r--r--dev-cpp/gccxml/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/gccxml/Manifest b/dev-cpp/gccxml/Manifest
new file mode 100644
index 000000000000..025f6936461f
--- /dev/null
+++ b/dev-cpp/gccxml/Manifest
@@ -0,0 +1,3 @@
+DIST gccxml-0.9.0_pre20131217.tar.xz 8134060 BLAKE2B d76d9710d9d5a1b1e8b111dbb93c7c2c53ae6162484490aad65a3349f1e29dd441864b32afec16f2c1f666c1577286306205e95eb22c778fff3294ce55f05d50 SHA512 3fedb2fb7ec8025921b4d416230acd8f5dcc01858089e12837d702bd4bec0f841ec23dfd949ae7ff42b559e5da1832bfc32ee24c1a4b3ff6004e73d49a1a81cf
+EBUILD gccxml-0.9.0_pre20131217.ebuild 770 BLAKE2B ad61969ec4a0aa060eddc251c44e42ac7899ab1dd1f332c0e898e4b9e9abbe0873c2571f6ba75199585454687d3dc691082e979c7892c4b95525f80ce98d6c3f SHA512 7c5900031a549c278d3c9f9a2f41e1c23c892951f2eedc077c62bbbf8b2faafac75d78f27f1534e96aa5077ae4526dfcc9322d02d6615c2230f7e5993a4f4683
+MISC metadata.xml 249 BLAKE2B 5791e38f31ac36bb4b94c03962980af247ea39c8af739a949749b1b3a7705ce4031ff53f620b1e4d30c44360e3d1d37ccb186ea109ecc1036977e4e0bb3a92e9 SHA512 0b2b2d015d6d3310efdedc20cd12cb2f587c105f1e84b243d3a7dc6337dde082c16683781eba9a0cb09341756f10f651579df35837ee232309a97017ec02cbee
diff --git a/dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild b/dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild
new file mode 100644
index 000000000000..ddd2732740d1
--- /dev/null
+++ b/dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="XML output extension to GCC"
+HOMEPAGE="http://www.gccxml.org/"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+src_prepare() {
+ # fix bug 549300 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ # patch below taken from Debian
+ sed -i \
+ -e 's/xatexit.c//' \
+ GCC/libiberty/CMakeLists.txt || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGCCXML_DOC_DIR:STRING="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/gccxml/metadata.xml b/dev-cpp/gccxml/metadata.xml
new file mode 100644
index 000000000000..d4905c84fc34
--- /dev/null
+++ b/dev-cpp/gccxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cpp@gentoo.org</email>
+ <name>Gentoo C++ Project</name>
+ </maintainer>
+</pkgmetadata>