summaryrefslogtreecommitdiff
path: root/dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 22:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 22:47:16 +0100
commit8993ea73a9714d22178ba6ada8c04be83cd71ec7 (patch)
treeeec3cc3c457b3e760f6ca631fd51e0c004705e88 /dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild
parentae838334efa4ecfd172331e8f5ae4eea8c5dd876 (diff)
gentoo auto-resync : 29:08:2022 - 22:47:16
Diffstat (limited to 'dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild')
-rw-r--r--dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild b/dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild
new file mode 100644
index 000000000000..5c158b468234
--- /dev/null
+++ b/dev-cpp/edencommon/edencommon-2022.08.29.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/folly
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="Shared library for Watchman and Eden projects"
+HOMEPAGE="https://github.com/facebookexperimental/edencommon"
+SRC_URI="https://github.com/facebookexperimental/edencommon/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="llvm-libunwind"
+
+RDEPEND="
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-cpp/folly:=
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/gtest
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake_src_configure
+}